Need help with a macbook pro OS X 10.6 stuck at apple logo

Discussion in 'MacBook Pro' started by N33H3LP, Aug 10, 2013.

  1. N33H3LP, Aug 10, 2013
    Last edited: Aug 10, 2013

    N33H3LP macrumors newbie

    Joined:
    Aug 10, 2013
    #1
    So my macbook pro has had some strange problems. It recently crashed and wouldn't get past the apple logo with spinning wheel, so I tried a lot of different fixes for it. Things I have tried:

    Resetting PRAM
    Starting in safe mode
    Starting in verbose mode
    Booting from disc
    Repairing disk using disk utility

    The only thing that initially worked was starting in single-user mode, using the command fsck -fy, then reboot. This got me into the desktop once. However, none of the applications would open, so I couldn't backup my data. Then the computer crashed again, and doing the same strategy either gets it stuck at the apple logo or a blue screen.

    The only clue I have to what is causing these problems is when I booted from disc and tried to repair disk permissions using disc utility. This found a bunch of different folders with incorrect permissions and it couldn't repair them. The SMART status on the drive is verified, also.

    Please help? Thanks for taking the time to read.

    EDIT: I also have a windows partition on the same harddrive which boots up no problem
     
  2. sofianito, Aug 10, 2013
    Last edited: Aug 10, 2013

    sofianito macrumors 65816

    sofianito

    Joined:
    Jan 14, 2011
    Location:
    Spain
    #2
    You must have done something before it started to crash... Do you get the BSOD? Have you installed some third party kernel extensions?...

    I get generally the spinning beach ball when I am running out of space. It doesn't crash, but it keeps spinning indefinitely and I can't get back control over Mac OS X (Lion). I end up doing a hardware shutdown...

    Did you try to boot with the install DVD and verify/repair disk /disk permissions?
    If it doesn't work try this as suggested by someone in another forum:
    Code:
    You can type the following in a terminal:
     
    - to verify permissions:
     
    diskutil verifyPermissions /
     
    - to repair permissions:
     
    sudo diskutil repairPermissions /
     
    - to check disk:
     
    diskutil verifyVolume
     
    - to repair disk, first boot from another volume (external drive, USB stick, DVD, … ), then display a list of all your mounted volumes in a terminal type:
     
    diskutil list
     
    - search for the identifier of the disk you want to repair in this list (could be disk1 but depends on how many disk you have attached to the server) and type:
     
    sudo diskutil repairVolume disk_your_number_here  //e.g. disk1
     
    - to learn all other options available with diskutil:
     
    man diskutil
     
    Hope this helps
    Did you run the Apple hardware test application?
     

Share This Page