need help

Discussion in 'iPhone' started by mervinb, Dec 28, 2011.

  1. mervinb macrumors newbie

    Joined:
    Dec 27, 2011
    #1
    need help guys i bought an iphone 4 and the version 5.0.1 and im trying to get it to work with tmobile any help is much appreciated!
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    If you just bought it, there is no way to get it running with T-Mobile.
     
  3. mervinb thread starter macrumors newbie

    Joined:
    Dec 27, 2011
    #3
    its not brand new i purchased it threw craiglist and i accidently updated it cuz i was stuck in recovery mode is there anyway i can still get it to work, if not ill probably just sell it thanks man
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    If you updated the baseband, there is no way to get it unlocked.
     
  5. mervinb thread starter macrumors newbie

    Joined:
    Dec 27, 2011
    #5
    **** man my baseband is 4.3.3 shouldnt that be able to work?

    ----------

    cant i just restore to a previous fireware? or once its updated i cant go back, or wait for dev team to come out with something? what do you suggest?
     
  6. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #6
    What is your baseband version? Not your iOS version.
     
  7. Thai4s, Dec 28, 2011
    Last edited: Dec 28, 2011

    Thai4s macrumors member

    Joined:
    Dec 28, 2011
    #7
    This here guy

    [​IMG]

    I can't believe people buy stuff from Craigslist.

    Apparently, if it's not like in that picture, you can't unlock your phone. You're screwed. Sell it to someone else.

    Version 01.59.00

    [​IMG]
     
  8. mervinb thread starter macrumors newbie

    Joined:
    Dec 27, 2011
    #8
    fml i cant even look at it now its saying activation required omgggggggggggggggg
     
  9. milani macrumors 68000

    milani

    Joined:
    Aug 8, 2008
    #9
    If you have a friend with an AT&T micro sim card borrow that and reset the phone in DFU mode. You might get lucky and reset it to the older baseband. No promises, though. And at the least you'll be able to use it as a wi-fi device for the time being (without cellular connectivity).
     
  10. mervinb thread starter macrumors newbie

    Joined:
    Dec 27, 2011
    #10
    thanks man! if it doesnt work should i buy a gevey sim?

    ----------

    it was in good condition man 10/10 and the modem firmware is 4.10.01
     
  11. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #11
    NO. He already updated to 5.0.1.
     
  12. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #12
    How do people do this?
     
  13. mervinb thread starter macrumors newbie

    Joined:
    Dec 27, 2011
    #13
    so im pretty much stuck is what your sayin.. okay im just gunna get rid of it then

    ----------

    craigslist was more convenient for me, what's the problem with craigslist you just got to be smart about it
     
  14. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #14
    If you updated to iOS 5 or 5.0.1 with iTunes, then your iPhone cannot be software or gevey unlocked.
     

Share This Page