Need to downgrade baseband from 04.05.04_G to 04.04.05_G

Discussion in 'Jailbreaks and iOS Hacks' started by SimonJ, Jul 11, 2008.

  1. SimonJ macrumors regular

    Joined:
    Jul 11, 2008
    Location:
    Czech Republic
    #1
    Hi guys, I hope you can help me with this... not so little problem.

    Here's the deal:
    I had a jailbroken and unlocked first gen iPhone (using pwnage tool, 1.1.4) I tried upgrading to the official 2.0 firmware (I know, I know). Now I have managed to almost completely revert back to 1.1.4 (as explained in one of the stickies) however my baseband version is still 04.05.04_G. As such I can't really restore or unlock my iPhone.

    It always boots into recovery mode and when I attempt to restore to the official 1.1.4, iTunes comes back with an unknown error 1604.

    DFU + restore gives me exactly the same error.

    What do you think I should do? Any help would be appreciated.
     
  2. aalonso331 macrumors newbie

    Joined:
    Jul 13, 2008
    #2
    I have the EXACT same situation. I have got the phone to work normally without the ability to make calls/text. So basically it's a iTouch. I am missing the tab under general settings (carrier) and it says "No Service" on top or just "..." I wish I never upgraded to 2.0! We might be okay soon, iPhone Dev Team has already unlocked the old iPhone with 2.0. They haven't release it yet, but when they do hopefully we will be going again!

    http://blog.iphone-dev.org/
     
  3. Warbrain macrumors 603

    Warbrain

    Joined:
    Jun 28, 2004
    Location:
    Chicago, IL
    #4

Share This Page