need to restore after 4.2.1 redsn0w JB... old shsh blobs on cydia, how do i get them?

Discussion in 'Jailbreaks and iOS Hacks' started by threetimesdaily, Dec 15, 2010.

  1. threetimesdaily macrumors member

    Joined:
    Aug 30, 2010
    #1
    right now I have an iphone 3GS (new bootroom) updated to 4.2.1 jailbroken with redsnow

    this iphone is not activated with itunes and will not restore bc of jailbreak.

    Pwnage tool does not allow me to restore with 4.2.1

    i need to downgrade to an older version with my shsh blobs on cydia.

    I have read tons of tutorials and tried desperately to figure this out, but I dont know how to retrieve these blobs from Cydia to use in Itunes to restore to one of these older versions.

    From my understanding, Tiny Umbrella is supposed to be able to read these blobs when my phone is connected. The only modes available on my phone are DFU or using redsn0w to boot tethered. neither of which is recognized by TinyUmbrella. I even manually entered the ECID but it says iphone is unconnected.

    This is my first time using Tiny Umbrella, so I do not have these blobs directly in the program, but all my old blobs are listed on my Cydia homescreen.

    *how do I pull these blobs from Cydia to use for restoring in itunes? am I looking for these blobs to be ipsw files? if not, what exactly are these blobs and how do I use them when using (Ctrl + restore) in itunes.

    I have tried to understand all the tutorials for this process, but I am missing some big clues I guess. everything else makes sense, but nothing I do allows me to see/use these blobs listed on Cydia.

    I know these questions are extensive, but I am running in circles and would greatly appreciate any insight.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    You can either use tinyumbrella to download the shsh's to your hard drive or you can edit your hosts file to redirect to cydias server and then itunes will let you restore to the ipsw of your choice assuming you have those blobs on cydia.
     
  3. threetimesdaily thread starter macrumors member

    Joined:
    Aug 30, 2010
    #3
    i have the blobs on cydia, i mean i must, because it lists 4 different previous blobs on the top of my cydia homescreen.

    i tried editing my hosts file to cydia's server, but was unnable to find any ipsw's i ran a search for ".ipsw" and found nothing. also tried browsing manually.

    i wanted to use tinyumbrella to download the shsh's to my hard drive, but tinyumbrella cant connect with my phone. i tried using redsn0w to "boot tethered" but when the phone turned on, tinyumbrella was not able to connect or recognize a connection with the iphone. same results with DFU mode.

    how can i get tinyumbrella to recognize the phone, or find the .ipsw files on cydia's server?
     
  4. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #4
    You don't use Tiny Umbrella to d/l IPSWs; you use google to find the correct IPSW. TU gives you offline access to your blobs, which tells Apple that you can install an iOS that Apple isn't signing for (currently, they're signing for 4.2.1).
     

Share This Page