Need to use æøå in WPA2 password...?

Discussion in 'macOS' started by Jodles, Apr 28, 2009.

  1. Jodles macrumors regular

    Joined:
    Dec 5, 2008
    #1
    Hi!

    I need to log onto a wireless network using WPA2 AES encryption. The password involves the letter "å" (Norwegian), and works on other PC's with Windows (thus WPA2 must accept these letters).

    But on OSX on my Macbook, I'm not even allowed to type this character in the password field; all I get is a biip.

    Does anyone have any idea? Is there any way to hardcode the password in some configuration file somewhere or some sort of workaround that could do this?

    It is not an option to change the password...

    I have English language used on the system, with Norwegian keyboard layout. I can type these funny characters when choosing for example WEP password, so my language settings shouldn't be a problem..?

    Thank you in advance!

    Best,
    Joachim
     
  2. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #2
    This doesn't help you at all, but I just tried to put Māori macrons in there and it wouldn't accept them either. So it's not just your particular computer causing problems.
     
  3. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #3
    Just something to try, do a copy and paste into the box. I don't have high hopes for that, but something that's easy enough to try.
     
  4. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
  5. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #5
    You might have some of these settings enabled already, but I just cover it from start to finish to make it easier.

    Head to the System Preferences and into International, then the Input Methods Tab. Select the "Show Input menu in menu bar" at the bottom.

    Then, click the Keyboard Viewer option in top of the main section of that window.

    After that, enable the layouts that you need. Obviously English and then whichever Norwegian layout you need (there are 2). You can then close the Sys Prefs.

    Now, from the Input Menu in the menu bar (in the upper right hand corner of your screen, denoted by the flag of whichever layout you are on), select the language you want to use and then select Show Keyboard Viewer. This will pop up an on screen keyboard which you can click to input characters. When you have Norwegian selected, you should see the å symbol, and it should let you input those special characters into any field, including ones for Airport passwords.
     
  6. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #6
    Just wanted to add that the above won't work for Japanese characters at least. When in the password field when I switch to Japanese layout it just switches back on me. Can't confirm this for a å character as the password field is just a bullet, and can't copy and paste from the field. I just typed it using alt+a, and the password field didn't give a beep so it may be working.
     

Share This Page