Network Drives Reconnects Over Wifi Instead of Ethernet

itsthenewdc

macrumors member
Original poster
Jul 10, 2008
95
116
Orlando, FL
I recently got a Mac Pro (2019). I've noticed some incredible slowdowns on my access to my Synology NAS and then realized it was using Wifi instead of the 10G Ethernet. I would turn off Wifi, reconnect to Synology, turn Wifi back on and everything would be fine.. until.. the computer goes to sleep and then when I come back it, for whatever reason, reconnects over wifi.

Is there anyway to stop/fix this? I need it to stay connected via 10G, otherwise it's incredible hassle to have to do the turn off/reconnect/turn on solution every single time I get back to the computer. It sort of defeats the purpose of a consistent connection.

I was previously using a 10G adaptor on my MacBook Pro and was told the Thunderbolt turns off when it goes to sleep, which is understandable, but a built-in 10G should not have this problem, especially since this is a workstation computer.. Why would it ever prioritize wifi over ethernet?

EDIT 1: Just incase anyone mentions it, my service order is Ethernet 1 > Ethernet 2 > Wifi.
 

barbu

macrumors 6502a
Jul 8, 2013
715
737
wpg.mb.ca
I am puzzled, because as you correctly identify, the Service Order is the way to manage this. It is not clear why this would not result in things working the way you want. Can you post a screenshot of your network prefs?
 

jeyf

macrumors 68000
Jan 20, 2009
1,699
761
download the latest Synology firmware

I dont know about the ThunderBoldt port but you should not be using it
so
seems like you have a wifi box in your home. Does this wifi box have ethernet ports, it so connect the NAS box ethernet to one of these ports. Set the wifi function in pass through mode. There is no need to have the NAS box any where near your work station. Physically re locate the Synology NAS box next to the wifi.
 

itsthenewdc

macrumors member
Original poster
Jul 10, 2008
95
116
Orlando, FL
I am puzzled, because as you correctly identify, the Service Order is the way to manage this. It is not clear why this would not result in things working the way you want. Can you post a screenshot of your network prefs?
Screen Shot 2020-02-10 at 4.29.01 PM.png

- - Post merged: - -

download the latest Synology firmware

I dont know about the ThunderBoldt port but you should not be using it
so
seems like you have a wifi box in your home. Does this wifi box have ethernet ports, it so connect the NAS box ethernet to one of these ports. Set the wifi function in pass through mode. There is no need to have the NAS box any where near your work station. Physically re locate the Synology NAS box next to the wifi.
Synology is up to date. Thunderbolt to 10GBe adaptor is used on my MacBook Pro to achieve 10G speeds. However, I'm more concerned with my Mac Pro (2019) workstation. The Mac Pro and Synology both connect to the 10G switch. The switch and Synology are located in a server rack.
 

RedTomato

macrumors 601
Mar 4, 2005
4,038
329
.. London ..
Can you not turn off the wifi on your Mac Pro? Why does it need to be on anyway - it should be receiving internet access via Ethernet anyway.
 

itsthenewdc

macrumors member
Original poster
Jul 10, 2008
95
116
Orlando, FL
Can you not turn off the wifi on your Mac Pro? Why does it need to be on anyway - it should be receiving internet access via Ethernet anyway.
I could, but I also use Maps and location based stuff somewhat regularly that forces Wifi to be on to pickup my location. I should also not have to turn off Wifi to solve a services order problem when the services order is properly set.
 

barbu

macrumors 6502a
Jul 8, 2013
715
737
wpg.mb.ca
I could, but I also use Maps and location based stuff somewhat regularly that forces Wifi to be on to pickup my location. I should also not have to turn off Wifi to solve a services order problem when the services order is properly set.
Agree that something is not working properly. One option is to leave Wifi on but leave disconnected from the network (ie “forget” the network). Then you still get location, airdrop etc but nothing will route over it. This is what I do with my iMac for the same reason.
 
  • Like
Reactions: RedTomato

itsthenewdc

macrumors member
Original poster
Jul 10, 2008
95
116
Orlando, FL
How do you know it is using Wifi instead of Ethernet for data transfers?
When it's on Ethernet it's getting 864 MB/s. When it's going at ~40 MB/s it's on Wifi. This is also confirmed because once I turn off Wifi, a few moments later the Synology disconnects from my computer. All I can think of is that for whatever reason when resuming from sleep it somehow sees Wifi first and no ethernet, and therefore tries to establish a connection with the Synology with Wifi.
 

RedTomato

macrumors 601
Mar 4, 2005
4,038
329
.. London ..
Agree that something is not working properly. One option is to leave Wifi on but leave disconnected from the network (ie “forget” the network). Then you still get location, airdrop etc but nothing will route over it. This is what I do with my iMac for the same reason.
This might fix it. It isn't ideal, but it seems a valid workaround to get you back up and working & with location awareness etc working.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.