New HDD with Mac OS 10.4.5 (Tiger) works externally, but not internally with Intel pr

Discussion in 'Mac mini' started by LongSlab, Jul 5, 2012.

  1. LongSlab macrumors newbie

    Joined:
    Jul 5, 2012
    #1
    Hello there,

    A few months ago, the internal Hard Disk Drive (100 Gb) of my Mac mini broke down (probably due to vibrations since when I opened the Mac mini I was amazed to find no fewer than 4 screws stuck to the speaker magnet!).
    Since the Apple Hardware Test detected no failure, I bought a new HDD (250 Gb, 2.5", SATA, Seagate) and, after several attempts, I am still nonplussed at its behaviour: it works externally via USB, but not internally!
    Here's the chronology of what 's happened so far:
    1. When I first mounted the new HDD internally, Disc Utility told me it was unable to partition it (I think the message was "Input/Output error").
    2. I took the new HDD out, connected it to the Mac mini via a USB and external HDD case. This time, Disc Utility let me partition the disc and instal Mac OS 10.4.5 on its volume with the help of the 2 install discs (My Mac mini had actually Mac OS 10.4.11, but the install disks that came with it were for Mac OS 10.4.5!). The external HDD manages to boot the Mac mini without problem in about 50".
    3. I've tried to mount the new, formatted HDD internally a couple of times since then: when I try to boot the Mac mini, the Apple logo appears fairly quickly on the screen (after 5" or so), but then no luck: after a minute or so, the Apple logo disappears and is replaced by a no-access icon like this: ⦰.

    4. Whenever I check the new, internally installed HDD with Disc Utility,

    a) it shows an icon of the Disc, but Disc Utility refuses to do anything to it (erase, partition, repair, verify, etc.). If I click Info, it tells me the capacity of the Disc is 1.8 Tb (instead of the actual 250 Gb). Here's some other info Disc Utility provides about this new HDD which might help explain why the processor and the HDD won't work together:
    Mac OS9 drivers installed: No
    Device Tree: /PC10@SATA@1F,2/@0:0
    Write Status: Read/Write
    Connection Bus: SATA

    b) If I do the same for the volume (called diskOs1 in grey), here's some info Disc Utility provides about it:
    Capacity: 1.8 Tb (that's wrong again, of course)
    Device Tree: /PC10@SATA@1F,2/@0:1
    Owners enabled: No
    Can be formatted: No
    Bootable: No

    Finally, here's some info …
    c) about the processor of my Mac mini:
    IntelCore Duo
    CPU Speed: 1.66 GHz
    Boot Rom version: MMII.0055.B08

    d) and about the serial-ATA
    Intel ICH7-M AHCI
    Speed: 1.5 Gigabit
    Description: AHCI Version 1.10 supported

    Has anyone any idea what might be the reason why the new HDD works when in an external case, but does not when installed inside the Mac mini? Thank you very much in advance.

    LongSlab
     
  2. Ragsd008 macrumors newbie

    Joined:
    Jan 17, 2013
    #2
    Boot up from the new hd externally. Update to 10.4.11. Then you will be able to install it internally and it will work. Had the exact same problem. Followed these instructions and it worked perfectly. Good luck
     

Share This Page