New iBook won't turn on!

Discussion in 'Macintosh Computers' started by Spartacus, Dec 1, 2004.

  1. Spartacus macrumors member

    Nov 28, 2004
    I just got my new iBook today. It worked great all day until I turned it off to restart after I connected it to my college's network. When I tried to turn it back on, the screen stays black but the internal fan starts whirring very loudly. Nothing more happens, the fan just whirrs and whirrs and the screen stays black. Does anyone know what could have caused this and/or how to fix it? I did put in a 1.0 gig stick of ram which was recognized and functional for most of the day (I installed it practically right out of the box) but I don't think that is the problem because it worked for a long time. This shutdown was also not the first one since installing the ram. Thanks!
  2. WCat macrumors member


    I would still suspect your RAM. It might have worked all day up until something failed, or it could be that the last reboot was the "final straw" that caused it to die. We call it infant mortality--something dies early in its life. Most manufacturers (the good ones, anyway) try and avoid this as much as possible by "burning in" chips or products for a while before shipping them, but it's still a fact of life that some really good products will still die when they get into the consumer's hands.

    Please try and see if your machine boots OK without the new RAM stick. If it does, then return the memory to the manufacturer or dealer and tell them what happened. I'd bet lunch that's your problem.

    By the way, I could be wrong here, but my iBook G4 will only take up to a max of 640 MB of RAM total, with the largest single RAM DIMM that I can stick in my empty slot being 512 megs. Unless Apple started shipping iBook G4's that can take more, your problem might well be that the 1 GB RAM module is "illegal." As far as I know, only Powerbooks can take the larger DIMM's. If that's the case, then the 1 GB stick will cause the problem that you're seeing--it's not defective, simply wrong for your iBook.


  3. earthtoandy macrumors 6502

    Jan 18, 2003
    the new ibooks have one open slot that can take up to a 1gig dimm giving you 1.25 total.

    i agree, try booting without the ram
  4. nagromme macrumors G5


    May 2, 2002
    My guess... it's a wake-from-sleep bug?

    Do you mean literally power it off? Or did you just put it to sleep (close the lid) so that the white light by the latch started to pulse?

    My guess is you just put it to sleep, and then woke it to a black screen. That's a known occasional issue, I believe--one that Apple is supposedly about to fix via software update with 10.3.7. (Or maybe they already did with 10.3.6--but I'm sitting that update out.)

    I've had that happen myself, and my fix is easy, as long as you don't have unsaved documents. Just hit Command-Option-Shift-Q. That logs you out instantly--and makes the screen come on to show the login screen. (If you have your machine set to ask for a password upon opening the lid, you'll have to do that first--blind--then press Return and THEN do the logout. Likewise, if you have an unsaved document open, hit Command-S to save before logging out.)

    BTW, you shouldn't have to sleep OR power down to connect to a network--but sleeping or logging out or restarting is sometimes worth a try in troubleshooting.

    Good luck.
  5. Spartacus thread starter macrumors member

    Nov 28, 2004

    Yes it was the ram. Thanks for your help everyone!

Share This Page