New mac mini > Choppy video playback in VLC for mkv or avi files

Discussion in 'Mac mini' started by savjag, Sep 30, 2010.

  1. savjag macrumors newbie

    Joined:
    Jun 24, 2009
    #1
    Just bought the new mac mini with HDMI out - 2.66Ghz, 8 Gb RAM, 500 Gb HDD

    A lot of mkv or avi files I playback appear pretty choppy in VLC - my primary app for watching movies and tv shows.

    I have a Drobo with two 2 TB SATA drives where I store all my stuff and which is connected to my mini via firewire 800.

    I've tried playing the same video back from both the Drobo and from the internal hard drive, to see if the choppiness was on account of the external drive or not. No difference really. A choppy video remains choppy from either place.

    It's pretty strange because some 1080p videos play just fine, with no choppiness whatsoever, while other 720p videos or even standard definition divx files are still choppy.

    Can anyone advise me on what my options are? Thanks a bunch in advance.
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
  3. savjag thread starter macrumors newbie

    Joined:
    Jun 24, 2009
    #3
    Tried Movist, much better video playback but no audio for most videos!

    @Spinnerly - Thanks v much. Every video I had a problem with works smoothly with Movist. However, it doesn't handle mkv audio as well as VLC does. Half my mkvs on Movist aren't playing audio back.

    Any clue? Otherwise, any alternative player recommendations?
     
  4. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #4
    That's strange as Movist handles my .mkv files better than VLC Player.
    There is also MPlayer OS X, which handles .mkv files Movist does not even open.

    Btw, have you looked under the "Movie" menu in Movist, if there may be another audio track?
    And if you still have problems, maybe use VideoSpec or MediaInfo Mac to analyse the .mkv file and attach the saved report(s) via the [​IMG] button to your next post.
     
  5. johosc macrumors newbie

    Joined:
    Apr 23, 2011
    #5
    I have a mini connected to my TV and have had problem with choppy video from almost any source. It turned out that my display update frequency was set to 24 Hz (in system preferences). After changing it to 60Hz it works fine with everyting from the internal DVD player to streaming from voddler.
     
  6. dolphin842 macrumors 65816

    dolphin842

    Joined:
    Jul 14, 2004
    #6
    I've been getting choppy playback as of late in VLC with 60fps h264 and DV files... might just be some nascent problems with the app itself at the moment.
     
  7. Calculon macrumors newbie

    Calculon

    Joined:
    Mar 26, 2011
    Location:
    The Future
    #7
    This worked for me

    I had the same issue.
    I found that changing a preference in VLC provided smooth playback.

    Go to Preferences (⌘,) click All preferences in the bottom left corner.
    - select Input/Codecs, then within that, Access modules, and finally within that, File.
    - change the Caching value (ms) to 800.
     

    Attached Files:

Share This Page