New screen problems...

paulnanrod

macrumors newbie
Original poster
Oct 8, 2012
4
0
I've recently replaced the LCD and screen on an 8gb iPhone 4. Since doing so the charge symbol doesn't appear and the tone to identify charging doesn't sound. As well as this the phone is no longer showing in iTunes when linked up to the mac.

Does anyone have any idea what may be the cause of this or the solution?

Thanks in advance
 

needfx

macrumors 68040
Aug 10, 2010
3,919
4,177
macrumors apparently
I've recently replaced the LCD and screen on an 8gb iPhone 4. Since doing so the charge symbol doesn't appear and the tone to identify charging doesn't sound. As well as this the phone is no longer showing in iTunes when linked up to the mac.

Does anyone have any idea what may be the cause of this or the solution?

Thanks in advance
maybe you should take it back to the shop that made the replacement

if you did it yourself, have you tried restoring the phone?
 

paulnanrod

macrumors newbie
Original poster
Oct 8, 2012
4
0
I replaced it myself. I want to back it up befor resetting it, but with the phone not being found on iTunes do you have any suggestions as to how I can back it up?

Thanks
 

paulnanrod

macrumors newbie
Original poster
Oct 8, 2012
4
0
Would that be one of the 5 connectors across the top?

They weren't named on the video-tutorial I watched!

It is charging, just very slowly (about 6% in an hour!) with no notification

Thanks
 

paulnanrod

macrumors newbie
Original poster
Oct 8, 2012
4
0
Is anyone able to help? If it is the dock connector, was this one of the 5 connectors, or is this the large ribbon-like cable at the bottom?

Thanks for any help
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.