Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

New Siri behaviour when controlling homekit accessories?

Squillace

macrumors regular
Original poster
Feb 22, 2016
105
50
Switzerland
Hi,

All the lamps I own in my apartment are Philips Hue and I control them exclusively via the Home(kit) app. Often I go to bed at night and just say "Hey Siri, turn off the lights" and it works like a charm.

Let me just put some clarification: my apartment is a 1 bedroom studio, I have an area with my office table/dinning table, and an area to sleep. I have one main bulb in the ceiling and two small bulbs in a design lamp next to my table. Most of the time those are ON and the main ceiling bulb is off. So, inside the Home app, I created both zones and each accessory attached to one of them.

The problem is since a few days ago (I couldn't remember when exactly), Siri wants for more details when I ask her to turn off the lights. She says: "Ok, which room?" (I actually have my phone in french so the translation may not be accurate) and it gives me a list of the rooms and an option to turn them ALL off.

Is this a new behaviour? Since when? Is there a way to revert to the old method?
If I'm more specific from the beginning and ask "Hey Siri, turn off ALL the lights" it works well. But I just never remember to say that sentence. I'm not used to it...

I joined a screenshot of Siri's answer, even if it's in french.

Thanks for your help
 

Attachments

  • IMG_1300.png
    IMG_1300.png
    1.1 MB · Views: 46

orbital~debris

macrumors 65816
Mar 3, 2004
1,017
1,357
UK, Europe
Hi @Squillace, I use "Hey Siri, good night" to turn off all the lights in my home at bedtime.

I'm not sure if this works unless you have a corresponding scene set up in Home (if not, just add all lights to the scene, set to off) but it's very easy to remember.
 
Comment

adrianlondon

macrumors 68030
Nov 28, 2013
2,719
2,700
Switzerland
It's relatively new behaviour (i.e. in the last beta or two). The "fix" is either to specify when you tell Siri what to do, or put all your lights in one "room" in the Home app. That's where it gets the info from.

I now say "all lights off" rather than just "lights off" to avoid the prompt.
 
  • Like
Reactions: chabig
Comment

orbital~debris

macrumors 65816
Mar 3, 2004
1,017
1,357
UK, Europe
It's relatively new behaviour (i.e. in the last beta or two). The "fix" is either to specify when you tell Siri what to do, or put all your lights in one "room" in the Home app. That's where it gets the info from.

I now say "all lights off" rather than just "lights off" to avoid the prompt.

I don't really get this assumption that everyone runs betas… Isn't it safer to presume common ground is the public release of an OS, given the range of Apple customers using these forums?
 
Comment

adrianlondon

macrumors 68030
Nov 28, 2013
2,719
2,700
Switzerland
It started for me after installing one of the betas. It may be an issue on a stock version too but I've not seen it mentioned elsewhere. The solution is the same.
 
Comment

Squillace

macrumors regular
Original poster
Feb 22, 2016
105
50
Switzerland
Thanks orbital~debris but workarounds were found. The thing is I would like to understand if and why something changed...

adrianlondon seams to confirm that something is different. Thanks for your help. I didn't install any of the iOS 14.x betas, so this must be something that came along with 14.0.1 for sure...
 
  • Like
Reactions: orbital~debris
Comment

Bogstandard

macrumors member
Aug 24, 2018
43
23
Mid West
Now, say "Hey Siri, turn off ALL the lights" and it will work perfectly.
This extinguishes all the lights in my house, including the pilot leds for my eero beacons.
I created a shortcut in homekit for a three word utterance. Two of 'Em are the wake words.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.