New WD Scorpio Black Hard Drive Not Recognised in 2010 Macbook Pro.

Discussion in 'MacBook Pro' started by CarbonShadow, Jan 14, 2013.

  1. CarbonShadow, Jan 14, 2013
    Last edited: Jan 14, 2013

    CarbonShadow macrumors newbie

    Joined:
    Jan 14, 2013
    #1
    So I've just bought a brand new WD Scorpio Black 750GB hard-drive on Amazon UK due to my previous hard-drive failing on me. But when I installed it into the Macbook Pro and booted up from the Mountain Lion Disk I created, it did not appear in disk utility.

    I don't think it's the SATA controller because after installing another hard-drive and booting up again, that hard drive was recognised. I then plugged the Scorpio drive into my Sharkoon external disk caddy and booted with the hard-drive connected through USB. This time the hard-drive was recognised and I could format it and install OS X 10.8 on it. I could then boot the hard-drive whilst it was externally connected to the mac, but when installed into the Macbook Pro it still wasn't recognised, but this time it had Mountain Lion installed on it.

    So my question is what is the problem are what are my solutions?

    I've already tried plugging the hard-drive externally into an iMac, formatting it on there and then installing it back into the Macbook Pro, but to no avail. I have not yet tried formatting it on a Windows machine, I don't know if this would help or make a difference. The other hard-drive I installed into the Macbook had previously been formatted on Windows but had files on it, so was not prepared to format it and try installing Mountain Lion on it.

    I've never had this much trouble installing hard-drives before, so I honestly don't know what the problem is. The Scorpio Black doesn't seem to be faulty as I could boot into OS X with it externally connected.

    So... what do I do?
     
  2. ocollus macrumors newbie

    Joined:
    Feb 20, 2013
    #2
    Hi. Did you solved you problem ? Im really interested, because i got the same situation. Please, help !
     

Share This Page