No 3G?

Discussion in 'iPhone' started by LouisLivesLife, Nov 8, 2011.

  1. LouisLivesLife macrumors regular

    LouisLivesLife

    Joined:
    Jun 11, 2011
    Location:
    Ghent, Belgium
    #1
    I've recently purchased a new iPhone 4s online via the apple site. One week later it arrived and I was the happiest man in the world!

    Though I have a question. There seems to be no option to turn on 3G in the Network settings! I live in Belgium and my provider deff. supports it..

    Do you have a solution?

    cheers, Lou
     
  2. Zcott macrumors 68020

    Joined:
    Oct 18, 2009
    Location:
    Belfast, Ireland
  3. steveca macrumors 6502

    Joined:
    Mar 9, 2005
    Location:
    Malta
    #3
    Hi,

    I think what you want is in settings >> general >> network and in that page you will have enable 3g
     
  4. HeezyBear macrumors regular

    Joined:
    May 21, 2010
    #4
    That won't work. The 4S currently does not have an option to turn off 3G. It is always on.
     
  5. yeah macrumors 6502a

    yeah

    Joined:
    Jul 12, 2011
    #5
    The antenna has no 3G on it (lol it says 2G talk time on website :D)
    It's like a see-saw:

    Better signal or EDGE?
     
  6. Mr.C macrumors 601

    Joined:
    Apr 3, 2011
    Location:
    London, UK.
    #6
    There seems to be some confusion in this thread. The OP wants to enable 3G not turn it off. According to the OP the phone is not picking up a 3G signal to begin with.
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    There is no option to turn off or on 3G on the 4S.
    3G is always on.
    If your phone doesnt connect to your carriers 3G network then do a reset network or contact your provider.
     
  8. hizzaah macrumors 6502

    Joined:
    Oct 22, 2011
    #8
    do you have a 3G plan? I'd contact your cell provider
     
  9. steveca macrumors 6502

    Joined:
    Mar 9, 2005
    Location:
    Malta
    #9
    sorry about that. i am on a 3gs in fact...
     
  10. dontwalkhand macrumors 601

    dontwalkhand

    Joined:
    Jul 5, 2007
    Location:
    Phoenix, AZ
    #10
    Call your cellular carrier and see what's up. Try also doing a reset network settings and see if that fixes it. I am not sure how carriers operate in Belgium, but you may be on some sort of EDGE only plan, or you may need to take it into Apple (if you have Apple stores near you) to swap it out (if you think something is wrong with the iPhone itself). Try different things like getting another SIM card etc.

    Did you have 3G with a past device that you've used with this carrier?
     

Share This Page