"No Audio Input/Output Devices Found" AKA The Bane of my Mac's life..

Discussion in 'macOS' started by ARPrada, Oct 10, 2013.

  1. ARPrada macrumors newbie

    Joined:
    Oct 10, 2013
    #1
    It was all good, until that damn 10.8.5 update...

    I have an iMac Early 2008 model (32bit), and for whatever reason after I made that update my audio devices stopped showing. At first a simple restart would fix it, but slowly it got worse. So I decided to reinstall the OS. That worked for an extra couple of days, and then it began to shut down on me again.

    This troubled me, so I started to research the problem. I decided maybe it'd be best to go back to 10.8, you know, when times were simple and care-free for me. This bought me a couple more days..then the problem arose again.

    To be specific:

    I go onto "Audio Midi Setup" and there are no devices found at all

    I go to "Sound" in the system preferences, there are no output or input devices to be selected.

    I normally run my computer's audio through an external audio interface (The M-Audio Firewire Solo) and when I load up the actual "M-Audio Fire Wire Solo" application, it detects that the interface is in fact there, and computer sounds (I.E emptying the trash, and turning on the computer) plays just fine through internal speakers/monitor speakers.

    I just can't get any music to play, or any audio other than said computer alerts.

    Things I've tried:

    Resetting the PRAM
    Downloading the Combo update
    Plugging speakers into the internal headphone jack
    Repairing Disk & Disk Permissions
    Restarting the computer, unplugging the power plug for 15sec, plugging back in.
    Downgrading to an earlier Mountain Lion software
    Reinstalling Firewire Solo's Drivers
    Upgrading BACK to 10.8.5(glutton for punishment?)

    I desperately need help guys.. I'm out of options it seems.
     
  2. ARPrada thread starter macrumors newbie

    Joined:
    Oct 10, 2013
    #2
    Update:

    Just a quick update..

    I manage to get the Firewire Solo up and running by unplugging & plugging back in, but that's a VERY short-lived victory.. It detects it, plays audio through iTunes, but then reverts back to not detecting it shortly after.

    Logic Pro 9 does not detect the interface at all, either.
     
  3. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #3
    Did you roll back to 10.8.4...?

    Others have said that 10.8.5 may have changed audio in some way. You may have more luck when 10.9 comes out.

    M-Audio are hopeless at keeping drivers up to date. After it took them six months to release drivers for Snow Leopard, so I ditched my M-Audio hardware and bought Edirol kit which is CoreAudio/CoreMIDI compliant, so doesn't need drivers on OS X.
     
  4. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #4
    Agree with benwiggy's post above.

    I suggest you find a firewire audio interface that is "CORE" driver-compliant -- that is, one that _doesn't need_ any drivers by which to connect to the Mac.

    M-Audio stuff is fine when it works, but they seem to have problems keeping their drivers current.

    You might also check over at gearslutz.com -- the members of that forum are usually up on such issues.

    I'd suggest you look for a used Echo "AudioFire" interface -- either an AudioFire4 or an AudioFire8. I use an AudioFire 8 -- easiest connection I ever made to my iMac, works with every system release and update. A very nice piece of equipment.
     

Share This Page