No connection to Volvo car stereo by USB after upgrade to iOS 4.2

Discussion in 'iPhone Tips, Help and Troubleshooting' started by sampdoria, Nov 28, 2010.

  1. sampdoria macrumors regular

    Joined:
    Jun 14, 2010
    #1
    The USB port in my 2011 Volvo XC90 worked beautifully until iOS 4.2. Now I get the "iPod unreadable" message on my car stereo. I'm using the AUX port with the headphone jack in the meantime until Apple fixes this bug. It's not very practical for a car manufacturer to be updating their software every time Apple upgrades theirs. Please let Apple know if you also are having this problem. Or post if you know how to fix without downgrading. Thnx.
     
  2. coonstz macrumors newbie

    Joined:
    Dec 10, 2010
    #2
    Same problem with our 2010 Volvo C70. My iPhone 4 used to work, now with 4.2.1 - doesn't work. My wife's iPhone 3GS with 4.1 - works.
     
  3. ciaphas macrumors newbie

    Joined:
    Dec 20, 2010
    Location:
    UK
    #3
    I just got a new V50, and I get the same issue when i try with my iphone 4. I called applecare, who at first refused to help me because I bought the phone more than 60 days ago. But when I got through to a senior technician, he said i could do one of the following to fix the issue:
    • Use a third party app to restore my iphone to the previous firmware, and in doing so void my warranty
    • Wait for new software to be released from Volvo to update the stereo
    • or go to my nearest apple store (60 miles away) to get them to test the iphone and make sure that it worked fine

    The bit I found the funniest is when I looked at the release notes for iOS 4.2, look here, it says under bug fixes, "Improves audio playback to car stereos via USB". So basically apple tried to change the software for usb car interfaces, and have well and truly screwed it up for everyone, and are now refusing to do anything to fix the issue.

    Apparately, this issue is not solely on Volvos, it also applies to Mercedes, BMW, Audi, Fords, and probably most others. I found a long thread on the apple forums with people asking apple to resolve this issue, and apple just ignoring them.
     
  4. chargit macrumors 6502a

    chargit

    Joined:
    Jan 17, 2010
    Location:
    Evansville, In
  5. ciaphas macrumors newbie

    Joined:
    Dec 20, 2010
    Location:
    UK
    #5
    I just did!!
     
  6. genereyes macrumors member

    Joined:
    Sep 19, 2007
    Location:
    northern VA, USA
    #6
    I can confirm it's not just Volvo. I have a 2010 BMW 328i, and iOS 4.2 results in garbage characters showing up on iDrive. For instance, a contact with a complete first and last name with phone number (e.g. "John Smith") on my iPhone 4 now shows up with garbage characters (e.g. ".@?").

    No pattern to the characters, deleting and resyncing Bluetooth doesn't work, restarting iPhone doesn't work... And yet, when my sister connects with her iPhone 4 (still running 4.1), the contacts show perfectly fine...

    Apple, I love your products, but some software "upgrades" are really DOWNgrades!!! :mad:
     

Share This Page