No dashes in phone numbers anymore?

Discussion in 'iPhone' started by creeman, Oct 15, 2011.

  1. creeman macrumors 6502

    Joined:
    Oct 15, 2007
    #1
    So, I restored my new iPhone 4S so I could restore from an iCloud backup because the guy at Verizon just set up my phone for me (Which I always find extremely annoying). But now, when I restore from the iPhone 4 iCloud backup I had, my contacts phone numbers have no dashes in them to separate the area code and the last four digits. Any idea on why? I restored my iPhone 4 from the same back up and the phone numbers come in fine.
     
  2. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
  3. creeman thread starter macrumors 6502

    Joined:
    Oct 15, 2007
    #3
    Set to United States. They were fine when I set it up as a new iPhone and then entered my iCloud information and synced contacts. But when I restored from my iCloud backup I get this.
     
  4. sweetwater10 macrumors newbie

    Joined:
    Oct 16, 2011
    #4
    same issue

    same issue here. i have two phones synced with the same iCloud account. one works just fine and includes the dashes. the other phone syncs all contacts and numbers but not the dashes so this causes the call log not to recognize the numbers. i verified all the settings on each phone are the same (they are) and I'm stuck. I've also restored ios5 and restored the backup from a few days back prior to upgrading to ios5. same issue. any suggestions?
     
  5. sweetwater10 macrumors newbie

    Joined:
    Oct 16, 2011
    #5
    I've done a bit more research and found that when I put a "+1" in front of the number, the dashes go in correctly and everything works properly. when i remove the "+1", the issue re-occurs.
     
  6. sweetwater10 macrumors newbie

    Joined:
    Oct 16, 2011
    #6
    fixed!

    here's what apple support had me to which fixed it:
    1. call verizon at *228 and hit option 1 to re-program
    2. double-tap home to get multi-tasking bar and kill the phone app (i killed all apps)
    3. check it out, it should work.
     
  7. SteelWheel macrumors member

    Joined:
    Apr 16, 2008
    #7
    I'm having a similar issue here. How do I "kill the phone app" after dialing *228?
     
  8. sweetwater10 macrumors newbie

    Joined:
    Oct 16, 2011
    #8
    Open the multitasking bar by double clicking the home button (it will slide up from the bottom). Then hold in the phone icon for about three seconds until it starts to jiggle. Then click the X in the upper right corner. Click the home button to return back to normal.
     
  9. phxoutdoorsman macrumors member

    phxoutdoorsman

    Joined:
    Oct 6, 2011
    Location:
    Phoenix, AZ
    #9
    I was having the same issue, thank you for the fix!
     
  10. slvrstn macrumors newbie

    Joined:
    Dec 6, 2011
  11. matthewcornell macrumors newbie

    Joined:
    Sep 15, 2008
    #11
    a) Thank you!! b) How the HELL did you figure this out? c) What's going on? I'm having the dreaded "calendar events created on iPhone don't sync with macbook iCal" problem repeatedly, and this contacts phone format problem is almost as much as I'm willing to put up with a phone created by Apple running an os created by Apple trying to work with a computer created by Apple running an os created by Apple. I wonder if they've gotten so big they've "Gone Microsoft" and can't write quality software anymore... Thoughts? Again, thank you!
     
  12. sweetwater10 macrumors newbie

    Joined:
    Oct 16, 2011
    #12
    no clue, sorry

    you're welcome! not really sure how I lucked out on that one, I'm glad I ended up calling verizon though as it sounds like it was a carrier-related issue. sorry - i cant be of any help with your ical issue. and i'm hoping i never experience it either! lol
     

Share This Page