No Finder under OSX10.3.1 after security update

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by Apostle, Dec 6, 2003.

  1. Apostle macrumors newbie

    Dec 6, 2003
    Belgium, Bruges
    I am typing this from one of the few programs that still run on my PB... Can't start anything but what is in my dock.

    A few events leading up to this situation:
    Performed the security update (5XII03)
    Simultaneously performed Soundtrack update (both from system preferences software updater)
    During cleanup:
    Put my crashed iPod in its cradle (stuck continuously restarting from the Apple logo after running completely out of juice)

    Big gray square appeared on screen, telling me in several different languages: a serious error has occured, restart computer by pressing the power button for 5 secs or press restart button.

    After restart:
    Computer restarts fine
    Login is ok
    Some startup programs launch fine (ms messenger)
    Classic tries to launch: requester appears telling me classic is not recommended on machines with less than 128Mb ram (i have 512, 'About this Mac' reports correct amount), does not continue launching (doesn't matter wether i click quit or continue)
    I can navigate the programs that are running, can navigate the dock, can start Safari, preferences,...
    From those programs i can choose file open, navigate my disks,... contents seem fine.

    CAN NOT:
    Launch Finder
    Do anything on desktop (nothing is there anyway)
    Open trash (which is essentially a finder window...)
    Launch some preference components (update, notably)

    Am stuck. Seek help.

    Anyone have a clue?

    Specifically, Anyone have tips on:
    How to start a console session
    How to start utilities not in dock

    Any help greatly appreciated,
  2. 1macker1 macrumors 65816


    Oct 9, 2003
    A Higher Level
    Can you get to the help option in the menu bar? If so you can type terminal, and some help options should come up for the terminal. It should say something like "Do you want to open terminal"
  3. Apostle thread starter macrumors newbie

    Dec 6, 2003
    Belgium, Bruges
    Have tried your suggestion (thank you),

    In the mean time have:
    Started up from OS install disk, run repair permissions two times (lots of repairs each time) and repair disk one time (no repairs necessary).

    Have downloaded security update from Apple (crash when the browser tries to mount the disk image).

    Have tried to use IE (opens most files, tho not programs) to open images of update: there isn't enough memory available.

    ?? Are the memory messages caused by the finder not running (does it manage virtual mem) or is the finder not running because i have mem problems. Note that 'About this mac' reports 512Mb SDRAM, but Classic won't start saying i have less than 128 available....
  4. Apostle thread starter macrumors newbie

    Dec 6, 2003
    Belgium, Bruges
    Update: when i use the link 'Open Terminal for me', i get the response: The item cannot be opened. It may be disabled or not installed.

    I could try starting up in console mode. Am not sure how i'm going to get the update reïnstalled through console commands... Any suggestions?

Share This Page