No haptic for Mail alerts

jazzer15

macrumors 6502
Original poster
Oct 8, 2010
414
62
I purchased a Series 5 watch about a month or so ago and have not been able to get it to provide a haptic alert when I receive email. I thought I changed all of the appropriate settings on the phone and watch and I receive screen notifications when mail comes in (on both the phone and watch) , but no watch vibration. Haptic works fine for messages.

Any ideas?
 

McKain

macrumors newbie
Dec 21, 2018
10
4
My settings:
on watch
Set mail to mirror iPhone

on iphone
Under notifications:
sound: vibrate only
ensure lock screen is enabled. For some reason this enables the haptic on the watch when an email is received.
This works for me
 

ledzepfan1981

macrumors 6502
Mar 11, 2015
433
55
I don't know about that app, but I don't get any haptic feedback from the Facebook and OneFootball apps.
 

xraydoc

macrumors demi-god
Oct 9, 2005
7,713
1,871
192.168.1.1
I purchased a Series 5 watch about a month or so ago and have not been able to get it to provide a haptic alert when I receive email. I thought I changed all of the appropriate settings on the phone and watch and I receive screen notifications when mail comes in (on both the phone and watch) , but no watch vibration. Haptic works fine for messages.

Any ideas?
Sound.
I bet you've turned off sound for mail notifications for that account on your iPhone.

For whatever reason, watch haptics are tied in to sound on the iPhone.

If you want the watch haptics but no sound on the phone when not wearing the watch, set the iPhone mail notification to a silent sound file as opposed to turning off audible alerts.
 
  • Like
Reactions: max2

jazzer15

macrumors 6502
Original poster
Oct 8, 2010
414
62
Sound.
I bet you've turned off sound for mail notifications for that account on your iPhone.

For whatever reason, watch haptics are tied in to sound on the iPhone.

If you want the watch haptics but no sound on the phone when not wearing the watch, set the iPhone mail notification to a silent sound file as opposed to turning off audible alerts.
Thanks.

Do you mean under “alert tones”? Under notifications I currently have Sounds set to “Vibrate Only”. Alert tones is set to “None” I think I did set it to use an alert ttone at one point to test it, but I can try again. I also have the phone in silent mode. To be clear, are you saying I need to set that to on and set up a silent sound file?

Oddly, I just received my first email haptic on the watch (no changes to settings yet) but I don't know why and I have received ither mail on that account today without any haptic alert.
 

xraydoc

macrumors demi-god
Oct 9, 2005
7,713
1,871
192.168.1.1
Thanks.

Do you mean under “alert tones”? Under notifications I currently have Sounds set to “Vibrate Only”. Alert tones is set to “None” I think I did set it to use an alert ttone at one point to test it, but I can try again. I also have the phone in silent mode. To be clear, are you saying I need to set that to on and set up a silent sound file?

Oddly, I just received my first email haptic on the watch (no changes to settings yet) but I don't know why and I have received ither mail on that account today without any haptic alert.
Yes, alert tones.
Notifications won't give a haptic if the alert tone is set to 'none'. At least watchOS 5 was like that. Haven't experimented to see if watchOS 6 is still like that.
 
  • Like
Reactions: jazzer15

jazzer15

macrumors 6502
Original poster
Oct 8, 2010
414
62
Yes, alert tones.
Notifications won't give a haptic if the alert tone is set to 'none'. At least watchOS 5 was like that. Haven't experimented to see if watchOS 6 is still like that.
Thanks very much.

I made that switch and it seems to be working now, but it is strange because I know I had tried that at some point and it didn't seem like it was working, so I set it back to "none".

I also made a change in the watch settings from "mirror my iPhone" to "custom" and turned notifications for the specific mail accounts that I want to get alerts from. I don't know if that had any effect, so I'll switch it back and see if everything continues to work (technically, it should, because that was all done in phone mail settings also).

Thanks again.
 

jazzer15

macrumors 6502
Original poster
Oct 8, 2010
414
62
OK. Now I'm really perplexed. I have 3 email acoounts. Notifications for one is turned off and on for the other two. Settings are exactly the same for each of the two that are tuened on and I am receiving screen notifications for both but only receiving haptic feedback for one. It doesn't make any sense.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.