No Haptic for Upcoming Events in Calendar after 2.0 upgrade

Discussion in 'Apple Watch' started by bumpylumpy, Oct 6, 2015.

  1. bumpylumpy macrumors member

    Joined:
    Mar 13, 2015
    #1
    One bug for me, not sure if it's just me -

    After the upgrade to Watch OS 2.0, if I set in the Watch App -> Calendar -> Upcoming Events (On) -> and set both Sound and Haptic on, I only get Sound alerts when events are about to happen. The haptic/vibration no longer works.

    I get haptic/vibration for other things; my Reminders for example. But no Calendar upcoming events. If I turn on the sound on the watch, I get the sound alerts so I know the alerts are definitely making it to the watch. And if I stare at the watch while the sound is off the screen lights and shows the event; it just doesn't actually vibrate.

    Unfortunately for me, this is my favorite "killer feature" - silently alerting me to the fact that I need to get to my next meeting, and it no longer works!

    I've tried restarting both my phone and watch and unpairing and re-pairing the watch to the phone.

    Anyone have any other suggestions?

    BTW, the iPhone is locked/screen asleep also when this happens.
     
  2. MoparShaha macrumors 68000

    MoparShaha

    Joined:
    May 15, 2003
    Location:
    San Francisco
    #2
    I've experienced this bug too. I usually have vibrate turned off for all calendar events on my iPhone. Turning vibrate on for alerts on the iPhone fixed the Taptic issue on the watch.

    Make sure you turn vibrate on in main "Sounds" settings, as well as in the "Notifications" in the iPhone settings for Calendar.
     
  3. bumpylumpy thread starter macrumors member

    Joined:
    Mar 13, 2015
    #3
    This solved my problem, thank you! Interesting that Apple has decided to tie the vibration settings for the iPhone to the haptic settings on the watch - that's not a clear relationship to me, but I guess maybe it makes sens for some people.

    Just for future reference, the only thing I needed to do was go into: Settings->Sounds->Calendar Alerts then inside there make sure there is some sound selected, then scroll way to the top and make sure Vibration is set to Quick (Default).

    Now I'm getting haptic messages on my watch again for calendar alerts! :)
     

Share This Page