No more sound in WarCraft III after 10.4.3 update

Discussion in 'Games' started by RHMMMM, Nov 6, 2005.

  1. RHMMMM macrumors member

    Aug 9, 2005
    Any ideas?

    I installed the 10.4.3 update and I noticed that I don't have any sound in Warcraft III any more. Is there anything I can do before I wipe it out and reinstall it?
  2. scphillipp1 macrumors newbie

    Nov 8, 2005
    #$%%!! same problem here!

    I've tried re-installing warcraft twice. I tried deleting every preference every setting I could think of. I even tried installing the game under a different user login. Still no sound at all in warcraft, not the game, and not the editor.
    If you (or anyone else) have a solution please post it or email me. I don't want to have to reinstall os x.
    steve in pa
  3. RandomDeadHead macrumors 6502

    Feb 8, 2003
    My son has complained of the same problem.
    Sorry, I have no solution.
  4. Soulstorm macrumors 68000


    Feb 1, 2005
    Perhaps is a problem of the Open AL sound... Have you tried doing the combo update instead of the delta update? It may seem irrelevant, but many users had problems with the incremental update.

    I have Warcraft 3 and it is running fine.
  5. riche macrumors newbie

    Nov 9, 2005
    South Wales
    Could this be the problem

    I had a similar problem and this solved it:

    No sound from some applications, but system alert sounds play (Mac OS X 10.3, 10.4)
    Some audio applications may change your computer's audio settings to a sample rate that is too high for other applications to use. In this situation, system alert sounds still work, and does iTunes, but other applications may have no sound (audio output). This document applies to Mac OS X 10.3 or later and applications that use QuickTime 6 for audio, such as Safari and Quicktime Player.

    This can happen on Macs that support high sample rates (higher than 48000 Hz):

    iMac G5
    Mac mini
    Power Mac G5 models that support sample rates higher than 48000 Hz
    PowerBook G4 support sample rates higher than 48000 Hz
    For example, if you play an Internet movie in Safari, it will make no sound; if you open a QuickTime movie on your computer, QuickTime Player reports the following error (and the movie will have no audio):

    "You may experience problems playing a sound track in (Movie Name).mov because a software component needed by the movie could not be opened."


    Open Audio MIDI Setup (/Applications/Utilities/), then check the Audio Output setting.
    Change the Audio Output setting to 44100.0 Hz.
    Quit Audio MIDI Setup.
    Why does this happen?

    Some third-party audio applications may change your computer's audio output setting. In fact, if you use the third-party application again after applying the above solution, the issue might occur again. Observe changes by watching the settings in Audio MIDI Setup before and after running a third-party application you suspect might be causing the issue. Contact the manufacturer of the application for more information.
  6. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    An alternative solution to the problem riche posted about is to open and then quit Garageband. It has the same effect. :)
  7. scphillipp1 macrumors newbie

    Nov 8, 2005
    I Cant Beleive It!

    OMG! I spent hours fixing permissions, restarting, reinstalling,pulling my hair out and opening garage band and re-closing - fixed it.
    Thanks everyone for your replies. This trick I won't forget!
    Steve in Pa.
  8. scphillipp1 macrumors newbie

    Nov 8, 2005
    will this nightmare ever end?

    now my sound works perfectly, but somehow in my uninstalling and reinstalling, I can not play (or host) any games on my local intra net. The games never appear at all on the other machine. I tried closing and reopening the firewall port as was suggested on another web site. AAAAAhhh - tonight was to be warcraft night! Any ideas? Thanks very much.
  9. scphillipp1 macrumors newbie

    Nov 8, 2005

    just tried alien vs predator, and it doesn't work over local intranet either, so it must be a setting within the network that got screwed up. I can go online with no problem, and see other computers on the network, but can't play games with others on my network. wahhhhh!
  10. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    I'm not a gamer so I don't know how helpful I can be. Maybe start a new thread (search first) to get better advice.

    Have you got a firewall on? Maybe turn it off.
  11. scphillipp1 macrumors newbie

    Nov 8, 2005
    yea, I do, that was one of the first things I tried -- I turned it off. Also read the log for any blocked items - none.
    tried turning off the airport card, restarting comp, resetting pram, turning off auto network, then back on, created new network, then back to old, reinstalled game under different (virgin) user - this told me it is not a local setting but rather a system setting.
    as you can see I've been busy for hours trying this again.

Share This Page