no or bad wifi connection with Belkin N1 router

Discussion in 'Mac Basics and Help' started by sophie8, Sep 2, 2009.

  1. sophie8 macrumors newbie

    Joined:
    Jul 31, 2009
    #1
    I bought a MacbookPro 3 weeks ago but never succeeded in connecting wireless to the internet properly with my Belkin N1 F5D8231-4 v2 router. The status is connected, airport is green, the bars are most of the time all black, but I can't open a page. Sometimes it does work, I am able to open a page, but then it falls out again. If it works, it's also very slow. All the other windows pc's and laptops in my house are working fine. Wired as well as wireless. I have called the Mac support line several times, we tried many things but it all didn't work. I also called Belkin four times, but they also don't seem to be able to fix the problem. I changed the channels and tried 6, 9 and 11, but without any result. According to Mac I need to reset the router, but Belkin is reluctant to do that since they are afraid that the other pc's and laptops won't work properly anymore after the resetting. I am able to connect wireless to the internet in the MacDonalds so I assume that there's no problem with my wireless card. According to Belkin there is a problem with my Mac and according to Mac there is a problem with Belkin, so there is no solution coming out. I was googling about this problem and found out that there are many problems with mac and belkin. It doesn't seem to be compatible. If so, what can I do about it? I can't change the router, because I am sharing the router with 6 other pc's/laptops in the house. It's really frustrating! Thanks!
     
  2. zagato27 macrumors 65816

    zagato27

    Joined:
    Aug 10, 2003
    Location:
    The Hill
    #2
    I just purchased a Belkin n+ router to go with my G5 and some iBooks, a PS3 and a Xbox along with a pc. Router works ok but my problem is that all the Macs seem to lose the connection with the router. According to my menu bar the airport is getting a good signal but I lose the internet. Cable modem (brand new Motorola SB6120 Surfboard DOCIS 3.0) is showing in the green and the belkin is all in the "blue". I have to go to preferences/network and do a diagnostic. Then all my dots go green and everything is great. I'm trying to figure this one out too. If you get any information please post. Cheers
     

Share This Page