No service after eBay unlock!

Discussion in 'iPhone' started by blakes, Jan 22, 2013.

  1. blakes macrumors newbie

    Joined:
    Oct 16, 2011
    Location:
    Long Island NY
    #1
    I purchased an unlock from unlock_fusion off EBAY, i got the email from them saying the phone is unlocked. restored in itunes and followed the instructions. i got the congratulations message but the phone isnt picking up signal from an active T-mobile. it only gets att service!
    the IMEI check says that my phone is unlocked BTW. anyone knows how to fix this?
    i also did restore multiple times(x10) at least and used different computers!
     
  2. fedecape macrumors 6502

    fedecape

    Joined:
    Oct 23, 2011
    Location:
    Miami, FL
    #2
    Did you cut the simcard? Does it fit properly?
     
  3. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #3
    Maybe you ruined the sim while cutting it to nano size.
     
  4. blakes thread starter macrumors newbie

    Joined:
    Oct 16, 2011
    Location:
    Long Island NY
    #4
    No it' s a T-mobile provided sim card that s in use in another iphone in the house!
     
  5. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #5
    Did the phone download the carrier update file?
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    Turn off 3G in the settings and give it sometime.
    It will say no service for a few minutes and then it will eventually connect and show tmobile on top left corner.
    If still nothing I'd try getting the nanosim replaced. If it was still locked it would display invalid sim card so its not an unlock issue.
    Has to be something with that sim card if the phone cant read it but it reads the att one fine.
     
  7. blakes thread starter macrumors newbie

    Joined:
    Oct 16, 2011
    Location:
    Long Island NY
    #7
    i will try another sim card in the phone but i m almost sure it is not a problem with it since it works flawlessly in the other phone. i also tried switching off 3g with no result. the iphone is an iphone 4 btw
     
  8. RotaryP7 macrumors 6502a

    Joined:
    Aug 31, 2011
    Location:
    Miami, FL
    #8
    The unlock works. It wouldn't say "No Service" w/ a T-Mobile SIM if it wasn't. The problem is either the SIM card or maybe T-Mobile has no coverage inside your house.
     
  9. blakes thread starter macrumors newbie

    Joined:
    Oct 16, 2011
    Location:
    Long Island NY
    #9
    i went to the apple store and they told me that there was no problem with the phone and it is indeed unlocked. they also said that certain phones do that once in a while and since there is now hardware problem(AT&T sim works) they can't swap it even though i got it 3 months ago. so technically now i have an unlocked phone that doesnt support T-Mobile!
     
  10. LoloBond macrumors 6502

    Joined:
    Nov 21, 2011
    #10
    Let me guess you went to Walt Whitman mall?! Certain phone just don't do that every once in a while... your phone is not downloading T-mobile settings for some reason. If the phone still under warranty the Apple store has to help you.
     
  11. blakes thread starter macrumors newbie

    Joined:
    Oct 16, 2011
    Location:
    Long Island NY
    #11
    No i went to the 5th ave store! i may go to a different one and see what they say!
     
  12. jerrahh macrumors regular

    Joined:
    Jul 7, 2010
    #12
    go to Roosevelt field they always do right by me.. they spent 2 hours with me and my apple tv to try and get it to find wifi, in the end they just gave me a brand new one.
     

Share This Page