Resolved No Sim problem

Discussion in 'iPhone' started by kerver, Jan 26, 2012.

  1. kerver, Jan 26, 2012
    Last edited: Jan 27, 2012

    kerver macrumors newbie

    Joined:
    Feb 17, 2011
    #1
    I recently updated my phone from 4.3.3 to 5.0.1. Everything was working fine until i did that. I jailbroke and unlocked. No sim, no carrier info. So I downgraded back to 4.3.3, jail broke, unlocked. Still "searching" or "no service" . I noticed it had read the iccid at one point but i still had no service. Now it's recognizing the carrier but in the about section is reading "no sim".

    I have taken my phone apart and checked the card reader...all looked fine in there...no missing/broken pieces.

    I've searched the net, and haven't found anything that fixes this.

    Like I said, my card reader worked fine before i updated.

    Why would it be reading the carrier and not the sim?

    Anyone have any advise for a fix to this....i love my phone....i want it back:(

    Thanks!


    16gb iphone 3gs
    06.15.00
    ios 4.3.3
     
  2. kerver thread starter macrumors newbie

    Joined:
    Feb 17, 2011
    #2
    Also, the wifi connection drops out every couple minutes...never used to do that ever either.......


    Anyone????
     
  3. kerver thread starter macrumors newbie

    Joined:
    Feb 17, 2011
    #3
    I've now downgraded to 4.1 and the wifi problem seems to be fixed now however the phone is now only recognizing my sim card and not the carrier, etc...

    I'm stumped!
     
  4. SpaceKitty macrumors 68040

    SpaceKitty

    Joined:
    Nov 9, 2008
    Location:
    Fort Collins Colorado
    #4
    Have you tried a new sim card tray?

    I had an 8GB 3GS that always gave me the message that there was no sim card. If I put it in a case, the message would go away.

    I finally got tired of the message when I took it out of a case that I took a sim card tray out of a white iPhone and put it in the black 3GS. No more no sim card warning.

    I finally sold the stupid phone and got another white 3GS.
     
  5. kerver thread starter macrumors newbie

    Joined:
    Feb 17, 2011
    #5
    Thanks for replying...I like your Avatar!

    I have tried switching out the sim tray...and sim tray with diff sim card....doesn't seem to matter.

    You know how usually when you take out the sim card you get a message that says "no sim card"....I don't get any messages at all.
     
  6. kerver thread starter macrumors newbie

    Joined:
    Feb 17, 2011
    #6
    Here's another update.

    I now have both carrier and sim showing up in the "about" section but no service its says in the top left corner.....this is bizarre!
     
  7. kerver thread starter macrumors newbie

    Joined:
    Feb 17, 2011
    #7
    FIXED!!

    I reinstalled my base band and it fixed the problem.

    All is well again!

    I'm back on 4.3.3 and won't be updating again unless i absolutely have to for whatever reason. I don't want to go through this hassel again!!

    I'm gonna look around at getting either a factory unlocked iphone or one for my carrier...too much bs otherwsie in my opinion.

    Cheers!
     
  8. macbookman83 macrumors 6502

    Joined:
    Jan 23, 2011
    Location:
    New York
    #8
    I agree is usually better to just have an official phone then to have to rely/depend on JBs
     

Share This Page