No sound coming from speakers and Red light coming from headphone jack...confused

Discussion in 'MacBook Pro' started by jawad7, Oct 10, 2007.

  1. jawad7 macrumors member

    Joined:
    Nov 8, 2003
    #1
    Hi,

    Wonder if anyone can shed any light on this problem - first time i have ever come across. I have a Intel 2 MacBook Pro. There is no sound coming from the speakers even though it is not muted and the vol is turned to the max. There is sound coming if i plug headphones in the jack. Just noticed that there is a red light coming from where the headphone jack is...anyone have any idea how i can get my speakers to work again?

    Massively confused - help appreciated.
     
  2. zioxide macrumors 603

    zioxide

    Joined:
    Dec 11, 2006
    #2
  3. rpetitto macrumors newbie

    Joined:
    Dec 27, 2010
    #3
    Solution

    Some members have stated that they inserted toothpicks, qtips, paperclips, audio/headphone prongs, etc into the headphone port to solve the situation. I did all of this to no avail.

    The one thing thing that worked was a stylus pen from an old pda that I had. Inserted it, swirled it around a couple of times, done and done!

    Hope for the best!
     
  4. jakebechtold macrumors member

    jakebechtold

    Joined:
    Jul 3, 2007
    Location:
    North Dakota
    #4
    AppleCare saved my @$$

    I had this happen to my mid-2009 MacBook Pro 13-inch. I inserted all kinds of foreign objects into the jack with no luck.

    If you are still under warranty (under either the included 1 year or AppleCare 3 year), your best bet is to take it to an Apple Store (or in my case an authorized Apple Retailer, as the closest Apple Store to me is 4hrs away) and have them repair it. In my case, they needed to replace the Logic Board (a $1400 repair job, mind you).

    This is also a good reason to ALWAYS buy the extended warranty on expensive electronics.
     
  5. chaoticbear macrumors 6502

    Joined:
    Jul 25, 2007
    #5
    I've been dealing with this for months - it used to be intermittent, and I could fix it by inserting a headphone plug a few times. I've accepted my computer's demise.

    But has anyone heard of the newer MBPs or MBAs having this issue?
     
  6. T34418leONE macrumors member

    Joined:
    Dec 3, 2010
    #6
    I've tried almost everything I've read to no avail.

    If the toothpick/cotton bud trick doesn't work, I've read to try a match. I've also read to try and plug in anything USB (iPod/external HD etc) then plug in headphones and then unplug them and that may help.

    Resetting your PRAM and MVRAM might help.
    http://support.apple.com/kb/ht1379 -steps here

    I guess the trick is to be gentle if you decide to stick a foreign object into the input and rotate clock wise. What you're attempting to do is hit a sensor and reset it so your MBP stops thinking that you have something plugged in.

    I'm at my wits end trying to solve this issue :(. Bought it used from a friend and he said it was a common problem and I'm trying to fix it and I can't get it yet!!

    I'm confident in taking my laptop apart- anybody know if there is a way to reset this sensor by taking the top case off and working from there?
     
  7. bfish3 macrumors newbie

    Joined:
    Jun 19, 2012
    #7
     

Share This Page