No Sound in some Games - Please Help this New Mac User!

Discussion in 'Games' started by Haoshiro, Feb 9, 2006.

  1. Haoshiro macrumors 68000


    Feb 9, 2006
    USA, KS

    I have a new iMac CD 20" (256MB VRAM, 1GB RAM) and have had some problems recently I haven't been able to figure out.

    The first game I installed was Starcraft and Broodwar, with the lastest patch (1.13f) and it worked great, no problems what so ever.

    I then installed WoW and patched up to 1.9.2 and it seemed to work fine as well. I waited to play it at all until 1.9.3 and it has worked great after that patch as well.

    I then Installed Warcraft III along with The Frozen Throne. I patched it to 1.20c; I did not play the game after installing it.

    Instead I went and installed Wolfenstein: Enemy Territory (2.60) and then opened it up. I was configuring the settings when I realized I had absolutely no sound.

    Puzzled, I opened WC3 - No sound. Then WoW - Sound worked fine. Then Starcraft - No Sound.

    I rebooted, and opened WC3. The "Blizzard" intro started (with sound) and I quickly cliked out of it to go straight in to the game - No sound. I tried all the games again and only WoW had working sound.

    I rebooted again, opened WC3 and the intro did not try to play; still no sound. Starcraft did not have sound either, even when clicking on the Watch Intro option.

    At this point I thought perhaps something with Rosetta was the problem. Even after rebooting and opening Starcraft first - A game that had worked fine *with* sound - the sound still did not work. WoW always works fine.

    Then I open up Big Bang Board Games - Reversi and also tried Checkers and Mancala... No Sound. The sound has always worked fine in these games.

    What could have happened? My sound works fine in normal use (iTunes, Adium, QuickTime, etc.) so I just do not know what is wrong. I ran TechTool Deluxe and the tests Passed fine.

    Any help is appreciated!
    ~ Hao
  2. Haoshiro thread starter macrumors 68000


    Feb 9, 2006
    USA, KS
    Issue Resolved

    I used Apple Chat and was able to get this problem resolved.

    I am not sure how it happened but the problem was with a setting in Audio MIDI Setup.

    To access this utility go to:
    Finder > Applications > Utilites > Audio MIDI Setup

    Click the "Audio Devices" tab.

    Set "Properties For:" to "Built-in Output"

    In the section labeled "Audio Output" in the lower-right set "Format:" to 44100.0Hz 2ch-16bit

    Mine was somehow set to 192000.0 Hz which was causing audio to not get outputted in some software (the games listed).

    death to self,
  3. bokdol macrumors 6502a


    Jul 23, 2002

Share This Page