No sounds on iPhone4

Discussion in 'iPhone' started by lilatheflirt, Jul 9, 2013.

  1. lilatheflirt macrumors member

    Joined:
    Jan 6, 2012
    #1
    Hi all. I was wondering if anybody had new ideas regarding this problem. It seems like it's stuck in dock connector mode. If I connect it to my dock, it plays music and movies sounds and has the keyboard and lock sounds. It also has no problem when I use the headphones. When I take it out of my dock or I don't use my headphones, it has no sounds. It rings when I have a call but that's it.

    I've tried a hard reset, turned the sounds on/off, reconnected it to my itunes account, connected/reconnected it to my dock along with my headphones. Do I need to set it up as new to fix this problem? I really don't want to do that so if anyone has ideas please help! Thanks!
     
  2. lilatheflirt thread starter macrumors member

    Joined:
    Jan 6, 2012
  3. ugcop macrumors 6502a

    ugcop

    Joined:
    Mar 15, 2012
    Location:
    Traveling @ Warp Speed ...... USA
    #3
    That is not that uncommon as several have had it happen. There seems to be a simple fix that I have read about here on the forum. At the time I can't recall what it is and I'm not in a position to search.
     
  4. stefanie7055 macrumors newbie

    stefanie7055

    Joined:
    May 4, 2013
    Location:
    Ontario
    #4
    My mom had this problem with her iPhone 5 and asked me about it...I told her to check her mute button. Sure enough, it was on - probably got bumped in her purse or something.

    Check your mute button.
     
  5. chumawumba macrumors 6502

    chumawumba

    Joined:
    Aug 9, 2012
    Location:
    Ask the NSA
    #5
    I had a Nexus One and that happened to it once. I smashed it with a hammer and got a new phone.
     
  6. toshibauser, Jul 11, 2013
    Last edited: Jul 11, 2013

    toshibauser macrumors member

    Joined:
    Mar 8, 2011
    Location:
    New York
    #6
    If you really wanna fix it youself, do following steps:
    First, try to clean install iOS, sometimes, it is a software problem. If that doesn't work. You have to open the case, check all the connectors. It could be that the speaker is not properly connected to the logic board.
    If none of above, you may have to replace the speaker yourself. Here is the manual you could use if you wanna do it yourself:
    http://www.ifixit.com/Guide/Installing+iPhone+4+Speaker+Enclosure/4360/1
     
  7. chumawumba macrumors 6502

    chumawumba

    Joined:
    Aug 9, 2012
    Location:
    Ask the NSA
    #7
    Too late for that.
     
  8. lilatheflirt thread starter macrumors member

    Joined:
    Jan 6, 2012
    #8
    If it's the speaker, it wouldn't ring when someone calls right?

    I may need to set it up as a new phone. That sucks.

    Thanks!


    And no, it's not the mute button. The phone rings during a call. No to text, lock, keyboard sounds along with music and movie sounds.
     
  9. toshibauser macrumors member

    Joined:
    Mar 8, 2011
    Location:
    New York
    #9
    iPhone has two speakers; one on the top controls the ring. It sounds like the main speaker got a problem which is at bottom of the phone.
    It could be a iOS problem; clean install it first, if it doesn't work, then replace the main speaker enclosure.
     
  10. lilatheflirt thread starter macrumors member

    Joined:
    Jan 6, 2012
    #10
    Thank you!

    I gather I need to replace the speaker as clean install did not fix it. :(
     

Share This Page