Not the usual 4S issue

twisted22

macrumors newbie
Original poster
Sep 24, 2012
2
0
I have a problem with my 4S in that when the screen goes dark in sleep mode it will no longer register an incoming call or text. What i mean is that i can't get a ring or text tone when the screen is blank. As long as the backlight is on like if im doing something on the phone when a call or text comes thru it operates normally. When it is in energy saver tho, and someone calls they just go straight to voicemail. This just started yesterday and the last thing i did before this happened is i uploaded my pics to my laptop from it. This is something i have never done before and may simply be a coincidence. I have read many complaints about speakers/volume not working but this isnt the same issue. Any thoughts or suggestions?
 

BasicGreatGuy

Contributor
Sep 21, 2012
11,884
10,925
In the middle of several books.
I have a problem with my 4S in that when the screen goes dark in sleep mode it will no longer register an incoming call or text. What i mean is that i can't get a ring or text tone when the screen is blank. As long as the backlight is on like if im doing something on the phone when a call or text comes thru it operates normally. When it is in energy saver tho, and someone calls they just go straight to voicemail. This just started yesterday and the last thing i did before this happened is i uploaded my pics to my laptop from it. This is something i have never done before and may simply be a coincidence. I have read many complaints about speakers/volume not working but this isnt the same issue. Any thoughts or suggestions?
Have you double-checked your settings? If so, have you tried resetting all to default? If that didn't work, have you tried restoring from a backup?
 

rhino89

macrumors regular
Nov 7, 2011
147
4
Did you by any chance play with the "do not disturb" settings? That would prevent your phone from lighting up with alerts, it would wait for you to wake it to notify you of what you missed.
 

twisted22

macrumors newbie
Original poster
Sep 24, 2012
2
0
Will check that right away. Not sure where to look tho but im guessing under settings somewhere.

----------

Bingo! Thanks for the tip. Is that setting only on the IOS6 or did i have it before i changed platforms and never noticed it?