O2 (UK) Still 'No Service' on my phone though have activated it

Discussion in 'iPhone Tips, Help and Troubleshooting' started by RealEvil, Jul 11, 2008.

  1. RealEvil macrumors 6502

    Joined:
    Aug 5, 2007
    #1
    Hi,

    So its 22 hours since I got the phone and it still does not work.

    i put the 3G sim in as I was told to do, and have spoken to O2 3 times. They dont even know I got an upgrade yet! I had to fill out a paper form in store as thier computers went down... They told me to wait up to 3 days... which is a real kick in the balls.

    What should I do? Im going crazy here! The phone 'works' apart from 'No Service' i.e. I can use a iPod and use some functions via wifi.
     
  2. Juo100 macrumors regular

    Joined:
    Sep 9, 2007
    #2
    Exactly the same situation here. If its not working by Monday ill go into the store and complain, this is a ****ing joke. I suppose there is nothing customer services can do until the stores take your details from notes to data.

    The guy that did mine said 2-24 hours and my friends said 48 hours, and now you've been told 72 hours. How long is it o_O

    Guess that’s how long then. http://www.o2.co.uk/iphone?cm_re=HeroBanner-_-Shop-_-iphone3GLaunch
     
  3. Georgea1990 Guest

    Joined:
    Jul 11, 2008
    #3
    Well where I was queues were huge and they told people that when the systems went up they would enter people in the order they signed up so for people like me near the front it could be as little as a few hours or tomorrow (which is now today) but the poeple who got the last iPhones it could be sunday or monday.
     
  4. BigBadJohn macrumors newbie

    Joined:
    Sep 23, 2007
    #4
    I'm having the same problem - mine is a new contract and on an Iphone from CPW online.

    I'm convinced mine is a physical problem with the new Sim they have provided. The chip is slightly off centre and is partially covered by the plastic holder. Interestingly my O2 payg chip works a treat so im hoping they can just transfer my plan to that.

    Anyone else got a dodgy O2 Sim?
     
  5. RealEvil thread starter macrumors 6502

    Joined:
    Aug 5, 2007
    #5
    So the old SIM may work? The guy in the O2 store was insistent that Iuse the new 3G sim...

    I think I will wander down to the O2 store this morning and complain. I appreciate some people dont even have a iPhone etc and we are lucky we do but I have paid for this and it doesnt work 23 hours later. They cannot blame iTunes anymore - that can activate fine now.
     
  6. markym07931 macrumors regular

    Joined:
    May 14, 2008
    #6
    i'm sure if you upgrade, you have to use your existing sim...

    i'm a brand new contract customer, and activated at home via itunes.. my sim for my new contract does nothing yet.. but the sim that i'm transferring (PAYG) works a treat, apart from that the internety stuff doesn't work. it says i ain't subscribed to data...

    if it ain't working by monday.. i'm gonna call them then.. i need to so i can make sure my PAYG number is ported!
     
  7. Marky macrumors regular

    Joined:
    Jan 4, 2005
    #7

    Just to clarify, when you ask will the old sim work, are you asking if the old sim from your previous iPhone will work?

    If that's the case then yes, upgraders are supposed to transfer their old iPhone's sim from it to the new iPhone 3g.

    Apologies if I've misunderstood the question tho.

    Regards
    Mark
     
  8. byron_hinson macrumors 6502

    Joined:
    Jun 3, 2003
    #8
    If you are doing an upgrade you HAVE to use the old O2 sim otherwise it doesn't work - they should have told you that.
     
  9. Willis macrumors 68020

    Willis

    Joined:
    Apr 23, 2006
    Location:
    What feels like the middle of nowhere
    #9
    2-3 days?! ooow I need the phone to work now..

    Been 25 Hours now since I left the Apple Store in Meadowhall. Ah well, as long as I'm near wifi, I'm happy.
     
  10. Expostie macrumors newbie

    Joined:
    Jul 12, 2008
    Location:
    Hull. East Yorkshire. England
    #10
    WiFi !!! no & still no service

    Mine will not connect with my wi fi went into 02 said should all be connected by Monday afternoon but till then wifi will not work either.
    sees my system but will not connect

    Cheers
     
  11. -Garry- macrumors 6502a

    -Garry-

    Joined:
    Oct 23, 2005
    Location:
    Manchester, UK
    #11
    My sim is the same but I wouldn't worry. I've had it in another unlocked phone and it still showed as inactive. Hurry up O2!
     
  12. Johnpartridge macrumors regular

    Joined:
    Feb 24, 2006
    #12
    Keep restarting your iphone guys. O2 said 72 hours for me. Just restarted and 3 txts from o2 all fully working. :) very happy, working great!
     
  13. -Garry- macrumors 6502a

    -Garry-

    Joined:
    Oct 23, 2005
    Location:
    Manchester, UK
    #13
    John are you an o2 or cpw customer? In store or mail order?
     
  14. LostLogik macrumors 6502a

    Joined:
    Jul 9, 2008
    #14
    Stuck waiting for O2 to sort their servers out (rang and was told still down.) could be some time before I can actually use this phone as my details were taken down on paper, which still need to be input on the system. Don't imagine they'll be done tomorrow, being Sunday, so that's another day shot. Then there is the delay of getting from input to actual activation, so probably looking at Tues at earliest. So glad I busted a gut getting this phone yesterday morning.
     
  15. Johnpartridge macrumors regular

    Joined:
    Feb 24, 2006
    #15
    I'm a o2 in store new contract customer.

    Putting wrong number in activation didn't matter after all!
     
  16. Georgea1990 Guest

    Joined:
    Jul 11, 2008
    #16
    what happened when you guys plugged in your iPhones because I only got the screens to register with apple, nothing to do with 02 or activation. Or will that come up once my sim is active?

    I'm getting abit confused.:confused:
     
  17. markym07931 macrumors regular

    Joined:
    May 14, 2008
    #17
    another meadowhaller... i was there too.. waited all day..

    activated on itunes at about 8pm last night, and 24 hours later, my sim worked... i had put a PAYG sim in though so it could have been sooner...

    wonder why you're not activated!
     
  18. drobles macrumors newbie

    Joined:
    Jul 12, 2008
    #18
    i'm confused as well, exactly the same happened to me... did you even get the phone number? because I didn't...
     
  19. Stalban macrumors newbie

    Joined:
    Jul 8, 2008
    #19
    I'm going to write to trading standards. This is ridiculous.
     
  20. drawds macrumors newbie

    Joined:
    Apr 11, 2006
    #20
    I will probably do the same - contact Ofcom on Monday.

    They should not have sold something that they cannot provide.

    Most frustrating thing is, my friends who got it after me already have their phones working cause they got it through O2 and I got mine through CPW online. :mad:

    I had to go and buy a Pay as you go simcard today to put on an old phone just so I could be reachable and call ppl.

    It's been 31 hours since activation and I still have no service.
     
  21. Georgea1990 Guest

    Joined:
    Jul 11, 2008
    #21
    Nope, at the moment its acting like an ipod, of course iTunes knows its an iPhone but i just have "No service" displayed on the iPhone and under the serial on itunes where the phone number usually goes I have an empty space.

    Though I did look on the O2 site today and it said this:

    "Customers new to O2 can start using their device once they have synced with iTunes and the phone account has been activated. When syncing with iTunes you may see 'Activation cannot be completed without service.' The activation of the mobile service for new customers will be within 2 to 3 days given the volume of sales on Friday."

    And I did see the "Activation cannot be completed without service" notice pop up on my phone so the conclustion that I have come to is that once O2 activate our phones will will get signal and be able to use it and just validate it when we plug it in after.
     
  22. markym07931 macrumors regular

    Joined:
    May 14, 2008
    #22
    do people realise that you actually have to turn the phone off, and on again to see if it is activated..

    just leaving it in and on, will do nothing..
     
  23. Georgea1990 Guest

    Joined:
    Jul 11, 2008
    #23
    I do keep switching it off and on every now and then, but the O2 shop did say they would call once they processed the activation and its still not happened!

    I just want to use my iPhone as a phone!!!
     
  24. drawds macrumors newbie

    Joined:
    Apr 11, 2006
    #24
    May I ask where you bought your phone from?
    CPW shop?
    CPW online?
    O2 shop?
    O2 online?
    Apple Store?

    I got mine from CPW online - and it seems that most problems are coming from those customers.
     
  25. markym07931 macrumors regular

    Joined:
    May 14, 2008
    #25
    hmm.. interesting that online customers are having the issues...

    i got mine at an apple store... the only issue I have right now is that mobileme doesn't push via wifi.... but it does via the network!

    M
     

Share This Page