Odd Firefox popup: Firefox wants to use a font to access a volume (huh?)

Discussion in 'Mac Apps and Mac App Store' started by glitch44, Apr 6, 2009.

  1. glitch44 macrumors 65816

    Joined:
    Feb 28, 2006
    #1
    I received an odd popup window in Firefox 3.0.8 on a Mac running Leopard 10.5.6

    It was:

    Firefox wants to use the font "Lucida Sans Unicode" on the volume "NO NAME".
    This font is not installed. Allow Firefox to use this font?

    [​IMG]

    Note: Volume "NO NAME" is my Boot Camp XP partition.
    Also, in the screenshot it says Firefox3 as I renamed the Firefox app that while testing version 3 while keeping version 2 on the drive.

    Does anyone recognize this popup?
    Why is FIrefox trying to access my Boot Camp partition?
    Why would it need to use a font on a volume?
     
  2. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #2
    it says it's not installed, not "not allowed"
    To me it looks like Firefox found a font on your bootcamp partition that isn't on your boot disk and it wants to use it.
     
  3. glitch44 thread starter macrumors 65816

    Joined:
    Feb 28, 2006
    #3
    You're right. Fixed the typo. But why would Firefox be trying to access my boot camp partition to begin with?
     
  4. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #4
    *shrugs*
    I would just hit don't allow. What were you doing to get this?
     
  5. glitch44 thread starter macrumors 65816

    Joined:
    Feb 28, 2006
    #5
    just surfing the net. nothing out of the ordinary.
     
  6. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #6
    I think Clevin would probably be the best bet for an answer on this one. He seems to be the resident expert on Firefox.
     
  7. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #7
    ah you called me out

    this is a first, I never seen this before.

    That being said, lets try these.

    1. since the pop says "firefox3 wants to..", this is a system message. not firefox pop up
    2. Does your firefox 3 share same profile with firefox 2? If so, try a new profile for firefox.
    3. what does your firefox font setting looks like?
    4. does this happen to a certain website? or at start of firefox?
     
  8. glitch44 thread starter macrumors 65816

    Joined:
    Feb 28, 2006
    #8
    Font settings are default. I was surfing around and it happened once, haven't been able to recreate it.

    It's a system message-- so Firefox is just trying to search for a font the page was coded in but it doesn't have? I guess that makes sense, I'm just confused how OS X knew l_10646.ttf is lucida sans unicode and that it's in the Windows > Fonts folder. Perhaps Spotlight indexes Boot Camp partitions?

    I guess I could try clearing out the system/ local / user font cache in case they're corrupted.
     
  9. ruinfx macrumors 6502a

    Joined:
    Feb 20, 2008
    #9
    i get it too on some sites. when i go to www.tastyblogsnack.com (lol) i get the same pop up but for lucida sans unicode. its weird how such an avid mac user would have a website that uses a windows font instead of lucida grande.
     
  10. tlacroix macrumors newbie

    Joined:
    May 20, 2009
    #10
    Faulty flash code

    I faced this message lately with a site I am developping :confused:

    After wondering for quite some time, I figured out it happened for the following reason.

    Flash applications embed the fonts they use within the Flash file, so they aren't needed on the viewer's computer. However, assigning a format to a text field before telling Flash to use the embedded font on that text field will cause Flash to try to use the locally available font, and this message to appear for Mac users that have the font installed locally (if they don't have it, no message appears from what I've seen so far.)

    Basically, I changed my AS3 code from this:

    myTextField.defaultTextFormat = myTextFormat;
    myTextField.embedFonts = true;


    to this:

    myTextField.embedFonts = true;
    myTextField.defaultTextFormat = myTextFormat;


    And voilà, no more annoying notice :D

    Tommy.
     
  11. glitch44 thread starter macrumors 65816

    Joined:
    Feb 28, 2006
  12. MacTAAMinator macrumors newbie

    Joined:
    Dec 21, 2009
    #12
    The problem is back

    Mac OS X 10.6.2

    Firefox 3.6B5

    The problem reared its ugly head. Even though you check the box that says to allow it and never ask, again, the popup asks every time Firefox starts.
     
  13. adder7712 macrumors 68000

    adder7712

    Joined:
    Mar 9, 2009
    Location:
    Canada
    #13
  14. pfiedler macrumors newbie

    Joined:
    Jan 24, 2010
    #14
    Font Message Problem Very Bad!

    I just upgraded to Firefox 3.6 (not the beta...the full release) and I'm now getting this font access message whenever I launch Firefox. I've tried rebuilding permissions and have responded to "don't ask me again..." in the dialog box that appears, but every time I open the application I must get 20-30 of these messages. They seem to come in small groups, then a break in the action, and then additional small groups (3-5 alerts).

    I installed Firefox v3.6 on 2 other Macs (running nearly identical systems) and there have been no problems on those machines. Each machine is running Suitcase Fusion v2 by the way.

    Hope somebody finds a cure to this incredibly annoying attribute.

    Thanks!

    Peter
     
  15. tingotanca macrumors newbie

    Joined:
    Feb 27, 2010
    Location:
    Planet Earth
    #15
    More information

    Greetings to you all. This problem has also been occurring for me, on a brand new MacBook Pro with SnowLeopard and a freshly installed, bookmarks excepted, Firefox 3.6. But it does not occur – never has – on my old G4 machines with Tiger and the same v. 3.6 of Firefox. All three machines are using the same "places.sqlite" (which now includes the bookmarks) file in the Firefox Profiles directory, the same preference settings for Firefox, and the same fonts (several 100's). I've done quite a bit of searching about, and I'd be inclined to think that it's an unhappy combination between the last Mac OS's and the last Firefoxes. I'm not offering a solution, but maybe some indications that might help others find one.

    I get the same message as Glitch44, but the external volume, used for backups, which it is calling for is a straightforward Mac-formatted one (no Windows or Boot Camp there) that was purchased and put in use at the same time as the MacBook.

    The fonts Firefox is calling for are rather unusual ones (some of them are for specialized linguistics, see list below) that are most unlikely to be used, even less so together, by anyone designing a website and its related css scripts. As far as mine are concerned, they date back to the days with Mac OS 9. They probably have never been used since, and certainly not on this new MacBook. But, again, they have been installed on it. Thanks to EasyFind, I also found out that they were registered in a number of files, such as:

    Office Font Cache (10), in User/Library/Preferences/Microsoft/
    At least 4 different files, in Library/Caches/com.apple.ATS/501/
    AdobeFnt.lst and UserCache.bin, in Library/Application Support/Adobe/Acrobat

    Their names also appear in three data files created by Word. Two of these are Word documents saved as Web html, and I'm gratified to find that Word has chosen to clutter them with the whole content of my font libraries! Yet, these html files are not even bookmarked in Firefox, so that's probably not where we have to look for an explanation.

    As to why choosing "Allow" is seemingly not remembered, I discovered by fuddling about that the setting gets temporarily stored in a file called "sessionstore.js" (I had replaced it between program launches, and the messages asking for all those fonts came back right away). Why the setting doesn't get remembered permanently between bootups might be understandable to someone more knowledgeable than myself, from the following (found in a file called "kernel.log"):

    Feb 25 15:30:42 [my user name] kernel[0]: firefox-bin[3783] Unable to clear quarantine `Avant Garde Mono ITCTT': 93
    Feb 25 15:30:46 [my user name] kernel[0]: firefox-bin[3783] Unable to clear quarantine `ProFont': 93
    Feb 25 15:30:49 [my user name] kernel[0]: firefox-bin[3783] Unable to clear quarantine `Classicalgreek-Translit.suit': 93
    Feb 25 15:30:51 [my user name] kernel[0]: firefox-bin[3783] Unable to clear quarantine `BancoITC TT-Heavy': 93
    Feb 25 15:30:54 [my user name] kernel[0]: firefox-bin[3783] Unable to clear quarantine `IranWeb2': 93
    Feb 25 15:30:57 [my user name] kernel[0]: firefox-bin[3783] Unable to clear quarantine `ProFontISOLatin1': 93
    Feb 25 15:31:00 [my user name] kernel[0]: firefox-bin[3783] Unable to clear quarantine `VNI-Times.fnt': 93

    The digits between [] after "firefox-bin" vary from launch to launch.

    Finally, choosing "Don't allow" seems to be a workaround, but that doesn't tell us what might come next. And the most nagging question still remains: why just those particular fonts, and not other fonts among those I've inherited from OS9, that are just as old, unused or peculiar?


    Next day, one slight correction: those peculiar fonts hadn't been installed yet the first time Firefox started requesting them from the external drive. But it kept on requesting them even after allowing and after they had been installed on the local drive.
     
  16. tingotanca macrumors newbie

    Joined:
    Feb 27, 2010
    Location:
    Planet Earth
    #16
    Further thoughts...

    Back to wondering how those fonts could be involved with Firefox in the first place. The only plausible explanation I got to so far is that the Firefox bookmark of a website written in, for example, Greek or Cyrillic, will be saved with its title (the TITLE tag) making a call to a font appropriate to those languages. This could apply beyond the need for language-specific fonts, of course.

    Transfering bookmarks from a machine where the fonts are installed to a machine where they are not could then theoretically result in Firefox trying to get them from another drive, in order to "satisfy" the requests of its bookmark file. If correct, this explanation still doesn't tell us why Firefox keeps on trying to get them from the external drive even after they have been installed locally and/or even after they have been accepted.
     
  17. Heb1228 macrumors 68020

    Heb1228

    Joined:
    Feb 3, 2004
    Location:
    Virginia Beach, VA
    #17
    Any new info on this issue? After recently upgrading Firefox, I'm getting 4 or 5 of these messages each time I launch Firefox. I'm about ready to trash it and just use Chrome as my secondary browser behind Safari.
     
  18. tingotanca macrumors newbie

    Joined:
    Feb 27, 2010
    Location:
    Planet Earth
    #18
    Gone

    The issue's gone here. Not a clue why. Maybe bc. of Firefox update?
     
  19. MacShopper macrumors newbie

    Joined:
    Nov 15, 2003
    Location:
    Eugene, Oregon
    #19
    This issue is not gone, I just got this font request for the first time. :confused:

    I'm running FF 3.6.12 on OSX 10.6.4.

    This popup has FF frozen until I click either Allow or Don't Allow, so I had to resort to using Safari to Google an answer, and that's what brought me to this forum.

    For the record, I'm not going to allow. If FF never needed it before, it shouldn't need it now. :mad:
     
  20. Berlepsch macrumors 6502

    Berlepsch

    Joined:
    Oct 22, 2007
    #20
    Have you tried "Font Book.app" to check that the font is correctly installed in OS X?
     
  21. MacShopper macrumors newbie

    Joined:
    Nov 15, 2003
    Location:
    Eugene, Oregon
    #21
    I checked and yes, it is correctly installed.

    I've only seen the popup that one time, so hopefully it was an anomaly.
     
  22. MatchEditPro macrumors newbie

    Joined:
    Nov 5, 2010
    Location:
    NYC
    #22
  23. tingotanca macrumors newbie

    Joined:
    Feb 27, 2010
    Location:
    Planet Earth
    #23
    Update one year later

    This particular issue has occurred again for me, shortly after inaugurating a new MacBook Pro (OSX 10.6.7). "Luckily", there were some new circumstances:


    1. It occurred not only with Firefox, but also when lauching Entourage (M$ Office's mail application). Forget about Firefox as being the guilty party, then. However, I was using Firefox 3.x and Entourage X last year, whereas I was now having this hassle with Firefox 4 and Entourage 2008.
    2. As far as Firefox was concerned, the request was for exactly the same fonts as had been the case previously.
    3. Most important: it did not happen during the whole time (several weeks) I was setting up the new machine and transferring the data, but only the moment I plugged in the external Firewire harddisk I had been using as a bootup disk on my previous PowerPC machine running OSX 10.4 (and when I launched the apps, of course). Which helped me understand why Firefox had stopped requesting those fonts: last July, I'd started using that external boot disk instead of the internal ATA disk which had become unreliable. Firefox was not requesting the fonts anymore simply because it was finding them on its own volume!
    While I don't understand the exact mechanism of it all, here's the workaround:

    • Write down the names of the fonts that are causing the hassle, then search for them on the external volume. Note that there might be multiple copies, in which case the apps will keep on requesting them (not only in the three default "Fonts" folders – I even found some hidden inside of the iMovie application package).
    • Transfer a copy of each one of them on your main bootup volume, then double-click on them, thus installing them on your startup system via Font Book.
    • Unplug the external disk.
    • Run the Resolve Duplicates routine in Font Book.
    • Plug the external disk in again and erase the original font files from it.

    So far, after going through this operation several days ago, I've been left in peace.
     

Share This Page