Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

odd gBand/ logic troubleshoot question

quigleybc

macrumors 68030
Original poster
Hey there,

So I use Logic 7.1 and garageband a lot. The other day i downloaded the new garageband update, 2.0.2 or whatever.

After doing so, all my garageband songs that I saved lost there garageband icon look and turned white. When I click on the new white file, it opens the saved song in Logic.... :confused:

I can open garageband by just clicking on the garageband icon and then opening one of the new white song files and the song opens the way it should. So it's not a disaster or anything...

but what happened?

I tried repairing permissions, and i guess the only other step is to uninstall garageband and reinstall from my iLife cd. But what the heck....It doesn't seem like other folks had this issue, so what gives?
 

WinterMute

Moderator emeritus
Jan 19, 2003
4,775
4
London, England
It's probably just a file type issue, try selecting a BG file (white one) and hitting "Apple+i" to bring up the info box, then change the "Open with..." dialog back to Garageband.

If this works you can grab another one and use the "Change all" button to change the GB files back to the correct filetype. You should get the icon back and it should auto-launch into garageband.
 
Comment

quigleybc

macrumors 68030
Original poster
WinterMute said:
It's probably just a file type issue, try selecting a BG file (white one) and hitting "Apple+i" to bring up the info box, then change the "Open with..." dialog back to Garageband.

If this works you can grab another one and use the "Change all" button to change the GB files back to the correct filetype. You should get the icon back and it should auto-launch into garageband.



hey thanks for the reply, I'll try that when I get home later, hope it works! :)
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.