Odd iPhone 4S connectivity issue

Discussion in 'iPhone' started by paulbennett95, Apr 23, 2013.

  1. paulbennett95 macrumors 6502a

    paulbennett95

    Joined:
    Aug 30, 2012
    Location:
    Long Island, NY
    #1
    I've recently switched my iPhone 4S to T-Mobile, and when I try to use either their "4G" or 2G I can only access the Internet through the safari address bar and sometimes the Facebook app.

    If I try to use twitter or any other Internet enabled app, or if I try to use the search bar in safari, either nothing loads or I get a connection error.

    If I type a website name into the address bar it sometimes works (I can't access macrumors that way, but if I go to google.com and search it I can access it fine, same with some other sites)

    Everything worked on my precious carrier (albeit very slow), so why not here? I obviously can connect to the Internet, and when I go to websites with 4G the speed is good (speedtest doesn't work so I can't get a number) so it's not connection issues. The number of cell bars makes no difference.

    I had nitrous and some other jailbreak tweaks but I restored from backup and went to 6.1.3 but it made no difference. Then I tried to set it as a new phone, yet again nothing, so now I'm back on my backup.

    Any suggestions? I asked on the T-Mobile forums and the one answer I got was to buy an new iPhone 5 (no) Would the apple store be able to help? I have no warranty or AppleCare.

    Thanks.
     
  2. Eniregnat macrumors 68000

    Eniregnat

    Joined:
    Jan 22, 2003
    Location:
    In your head.
  3. paulbennett95 thread starter macrumors 6502a

    paulbennett95

    Joined:
    Aug 30, 2012
    Location:
    Long Island, NY
    #3
    But why would the Internet work on safari but not other places?
    If I was getting frequencies I couldn't receive then i wouldn't have Internet access at all but I do so...?
     
  4. paulbennett95 thread starter macrumors 6502a

    paulbennett95

    Joined:
    Aug 30, 2012
    Location:
    Long Island, NY
    #4
    Resetting network settings seemed to fix everything.
     
  5. nancyfromafrica macrumors member

    Joined:
    Sep 17, 2012
    Location:
    Johannesburg
    #5
    try this internet setup guide

    Code:
    http://snapguide.com/guides/manually-set-up-apn-internet-settings-on-iphone-4-1/
     

Share This Page