Odd issue with my new 21.5 iMac (keystrokes making an odd sound emit from speakers)

Discussion in 'iMac' started by Whackintosh, Mar 12, 2013.

  1. Whackintosh macrumors 6502

    Joined:
    Mar 8, 2009
    #1
    I've never had this issue with all my years of using macs. Whenever I type, each key hit makes a brief, soft static-like sound come from my speakers. I tried turning my (external) speakers off and the sound continued to be made with every keystroke, only now it was coming from the iMac's internal speakers. Has anyone else experienced this? I hope there's an easy way to stop it!

    ----------

    I tried re-starting my machine, btw. No difference.
     
  2. macthefork, Mar 12, 2013
    Last edited: Mar 12, 2013

    macthefork macrumors 6502

    Joined:
    Feb 2, 2013
    #2
    Turn off “Play user interface sounds” in System Preferences, under Sound > Sound Effects.

    Or, under Accessibility > Keyboard > Slow Keys "Options"turn off “Use click key sounds”
     
  3. Whackintosh, Mar 12, 2013
    Last edited: Mar 12, 2013

    Whackintosh thread starter macrumors 6502

    Joined:
    Mar 8, 2009
    #3
    Ah, thank you, that did it! It was a "user interface sound" that needed to be disabled. Was never even aware of this on my previous machines, for some reason. I wonder why anyone would want that static sound in the first place?
     
  4. WilliamG macrumors 604

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #4
    Well, don't enable it if you don't want it! And yes, I say that because it sure as heck didn't enable itself!
     
  5. macthefork macrumors 6502

    Joined:
    Feb 2, 2013
    #5
    Actually, it's on his new computer. This kind of thing is common when updating from an older computer/OS, the default settings have to be changed. That very thing happened on mine when it was new. However, I knew where to look to correct it.

    So... it certainly could have enabled itself as a default on a new system.
     
  6. MacTech68, Mar 12, 2013
    Last edited: Mar 12, 2013

    MacTech68 macrumors 68000

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #6
    Actually, these services have been around since system 7 with a control panel called "Easy Access" with settings like 'sticky keys'.

    These used to 'mysteriously' enable themselves due to the fact that pressing the shift key three times in quick succession turns the feature on.

    If you look at the Preference Panel in MacOS X, you'll find the same key-stroke enablers, so sometimes, whilst the computer IS doing what it's told, the user is un-aware of the keystroke and inadvertently enables it.

    Pressing the shift key FIVE times in MacOS X 10.6.8 turns "Sticky Keys" on and off.

    Pressing the option key FIVE times turns "Mouse Keys" on and off.

    You DO have the option to disable those keystrokes from working - which should be the default.

    Just my 2c
     

Share This Page