On safari I can't stay logged into gmail or facebook

Discussion in 'iPhone' started by Mad Mac Maniac, Apr 8, 2009.

  1. Mad Mac Maniac macrumors 601

    Mad Mac Maniac

    Joined:
    Oct 4, 2007
    Location:
    A little bit of here and a little bit of there.
    #1
    Ok, so I have noticed this problem with facebook ever since I got my iphone. If I ever use the browser version of facebook, I am automatically logged out within 5 seconds. I have always been annoyed by this but have been able to live with it because the fb app provides most functionality.

    Now for the first time, I have attempted to log in to my gmail account on the browser, because I saw a CNN article about how it's all new and improved on the iphone. I am logged out within 5 seconds and am unable to stay in.

    Does anybody know why in the world this is happening? My setting javascript, plug-ins, and block pop-ups are all set to ON. Accept cookies from visited. This is a bit annoying.
     
  2. cellocello macrumors 68000

    cellocello

    Joined:
    Jul 31, 2008
    Location:
    Toronto, ON
    #3
    This has always been a problem for you?

    If rebooting doesn't help, try restoring.

    Other than that, not sure what to tell ya.
     
  3. Roessnakhan macrumors 68040

    Roessnakhan

    Joined:
    Sep 16, 2007
    Location:
    ABQ
    #4
    Try clearing your browser cache and restarting the phone. I'd also suggest the iPhone facebook app, and even setting up Mail for GMail.
     
  4. Mad Mac Maniac thread starter macrumors 601

    Mad Mac Maniac

    Joined:
    Oct 4, 2007
    Location:
    A little bit of here and a little bit of there.
    #5
    Yes I have had this problem ever since I first tried to log into facebook about 8 months ago. So many reboots have occured since then.

    And yes I DO have the fb app and have gmail set up on my mail app. That is why it hasn't really been such an issue in the 9 months that I've had my iPhone. I've actually seeked help in these forums before about the facebook issue, because I initially thought that was the only instance of the error. But now I'm noticing that gmail does the same thing. The apps can get you by, but occasionally I like the full functionality that I can get off the web. I'm sure this is the same for other login websites.... I haven't really investigated it...

    EDIT: same results on yahoo mail and digg
     
  5. cellocello macrumors 68000

    cellocello

    Joined:
    Jul 31, 2008
    Location:
    Toronto, ON
    #6
    Seems like a software problem.

    If cache and cookie clearing don't help, you may want to try a full restore.
     
  6. Mad Mac Maniac thread starter macrumors 601

    Mad Mac Maniac

    Joined:
    Oct 4, 2007
    Location:
    A little bit of here and a little bit of there.
    #7
    nope. Guess I'll have to do a full restore when I get a chance
     
  7. cWeems macrumors 6502a

    cWeems

    Joined:
    Jun 8, 2008
    Location:
    FLORIDA, USA
  8. jeremykyle macrumors regular

    Joined:
    Feb 8, 2009
    #9
    Even though I do use the apps, Safari has NEVER kept me logged in after I closed it. I just always thought this functionality wasn't there.
     
  9. Aaleck macrumors 6502a

    Aaleck

    Joined:
    Oct 11, 2007
    Location:
    Michigan, USA
    #10
    Never really noticed... Don't really use anything that requires me to login on my iphone...besides macrumors, which keeps me logged in when im using it...
     
  10. cellocello macrumors 68000

    cellocello

    Joined:
    Jul 31, 2008
    Location:
    Toronto, ON
    #11
    It works on my phone.

    Digg, MacRumours, Gmail, Facebook and so on all keep me logged in.
     
  11. Mad Mac Maniac thread starter macrumors 601

    Mad Mac Maniac

    Joined:
    Oct 4, 2007
    Location:
    A little bit of here and a little bit of there.
    #12
    update:

    Did a full restore... Still logs me out immediately (not just the next time I open safari but before I can even open an email or check a fb message. That is kinda lame. It even does it on MacRumors now and I seem to remember being able to post in MacRumors last summer.

    Does this mean all is lost?
     
  12. moka macrumors 6502a

    Joined:
    Aug 11, 2008
    Location:
    California
    #13
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_2_1 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5H11 Safari/525.20)

    Is your phone jailbroken? Has it ever Been jailbroken? Because it's deffinatly a user permission problem with your files. If you are jail broken use sbssettings to fix the user permission problem.
     
  13. Mad Mac Maniac thread starter macrumors 601

    Mad Mac Maniac

    Joined:
    Oct 4, 2007
    Location:
    A little bit of here and a little bit of there.
    #14
    I had it jailbroken for a few weeks. Right before the 2.1 update. Then I haven't jailbroken it back because I didn't really like it.
     
  14. Mad Mac Maniac thread starter macrumors 601

    Mad Mac Maniac

    Joined:
    Oct 4, 2007
    Location:
    A little bit of here and a little bit of there.
    #15
    So any way to fix it without jailbreaking?
     

Share This Page