One 4k Monitor works and another doesn't....

Discussion in 'MacBook' started by bluewooster, Apr 10, 2017.

  1. bluewooster macrumors member

    Joined:
    Jul 18, 2007
    #1
    Hoping someone can shed some light on this issue I'm having with my 2015 rMB....

    I have a Samsung 28 inch 4k monitor that works very well using the Apple AV multipart hub and a 2.0 HDMI cable. I get 4k at 30 Hz with all the scalable HiDPI options (see screenshot).

    I bought another 4k monitor for my office (a 32 inch 4k by AOC) under the assumption it would work just as well. Using the same hub and HDMI cable, I get 4k at 30 Hz but only native resolution. None of the scalable options show. If I "alt" click on the scalable radio button, I only see low resolution options. By using the instructions at this site, I was able to create a 1920x1080 HiDPI option but that's it. I don't get the very helpful and useable options I get on the Samsung (1440 HiDPI in particular).

    The monitor seems to have the same specs and has both HDMI 2.0 and DP 1.2. I've tried looking at the monitor options but don't see any settings that should effect this (I can change the HDMI port to 1.4 and tried this but it made no difference).

    Unfortunately, I bought the monitor from a local smaller store and they made a point of telling me that there are no returns! Looks like I'm stuck using native 4k or 1080 HiDPI.

    Does anyone have any suggestions, or at the very least, an explanation why this monitor won't work?
    Thanks in advance.
     

    Attached Files:

  2. sakabaro macrumors regular

    Joined:
    Feb 24, 2015
    #2
    Isn't 30 Hz very annoying to drive a monitor with?

    To answer you question, this can be useful: https://superuser.com/questions/1116866/macos-sierra-doesnt-scale-for-4k-monitor/1126490
     
  3. bluewooster thread starter macrumors member

    Joined:
    Jul 18, 2007
    #3
    Thanks for the reply and the link - it describes a similar issue but no solution unfortunately.

    Today, I took my rMB and hub to a store and tried out a couple different 4k monitors and, again, strange results. One (an Asus I believe), behaved like my Samsung, displaying the graphical buttons for various scaling options (such as in my screenshot above). The other (don't recall the brand), actually didn't show an extended desktop at all but, rather, it was a mirrored desktop and I couldn't seem to change this by unchecking the mirrored desktop option. It displayed graphical buttons for scaling but only up to a very low effective resolution.

    I'm still not sure why some monitors would seem to work easily "out of the box" and others not (though I am sure there is an explanation that I'm just not smart enough to know!). I'm also not sure why some monitors give the graphical buttons for scaling and others just give a text list to select from.

    As for the 30Hz, it isn't ideal but I haven't found it as distracting or frustrating as others have described (but my use might be atypical - some programming and some music composition). I would definitely like to use the display port to get 60 Hz but, despite frequent googling, I've never found a hub that allows charging and has a display port that you can actually buy! If I upgrade to a MBP with more ports, I'd probably use a USB-c to Display port cable for the monitor and the charge cable in another port.
     
  4. bluewooster thread starter macrumors member

    Joined:
    Jul 18, 2007
    #4
    Replying to myself in case someone encounters a similar problem with a 4k monitor....

    Going into the monitor settings, I tried changing the HDMI port back to 1.4 (from 2.0). I had done this before without result but, this time, I reset the computer and, lo and behold, there are all my scaling options! (with the graphical selection as above)

    I'm not entirely sure why this is the case but I'll take the result!
     
  5. Admiral macrumors regular

    Admiral

    Joined:
    Mar 14, 2015
    #5
    How do you change the HDMI port (on which device, your computer or your monitor?) to 1.4b from 2.0?
     
  6. bluewooster thread starter macrumors member

    Joined:
    Jul 18, 2007
    #6
    It was a setting in a hidden menu on my monitor. My other monitor only has 1.4b (no 2.0) so that's probably why it "just worked". It also probably explains why I was having such sporadic luck when I took my computer to Best Buy to try some different monitors.

    I'm guessing this is a limitation of the AV display hub. I had borrowed a friends TbMBP and it had the same issues when using the Apple AV multiport hub. Likely a USB-c to HDMI cable wouldn't have this issue (and could probably use HDMI 2.0 for 4k at 60 Hz)? (I've never tried one)

    Still, for anyone using a hub who hasn't been happy with the scaling options on their 4k monitor, I would advise changing the port to 1.4b (if you can) thru the monitor settings and then resetting their computer. It did the trick for me!
     

Share This Page