One of the USB ports on MBP13" 2011 does not work.

Discussion in 'Mac Accessories' started by DudeMartin, May 20, 2012.

  1. DudeMartin macrumors regular

    Joined:
    Dec 2, 2010
    Location:
    Chicago, Illinois
    #1
    I've had my MacBook Pro 13" for almost 2 years now. This problem has been hanging around for a while but I've been able to live with it because there has usually been an easy walk-around.

    On my MBP, one of the two USB ports does not work almost all of the time. It is the top port, the one closer to the power supply port. The reason why I say mot of the time it does not work is because some devices are able to work with it. I had a pair of headphones that also had a microphone that used USB and a 3.5mm port. I could plug the USB into the "dysfunctional" port and the 3.5mm into the shared Audio In/Out port and it would work just fine.

    Recently, those headphones broke and I picked up a new pair of headphones that I really liked. I specifically looked for a set-up that did not require two 3.5mm ports because the 13" model only has one. When I found one (this setup had only a USB - no 3.5mm), I bought it home and plugged the USB cable into the "dysfunctional" USB port. I heard no sound. I went to the Audio settings and I saw that no new Audio Output devices showed up when I plugged the headphones in. I unplugged everything from my two USB ports and I plugged the headphones into the other USB port that has no problems. Suddenly, the headphones were recognized and they worked without a problem. But I also use a USB mouse. Then, I plugged into the USB mouse that had previously used the "good" port into the "bad" one, and the mouse stopped working. The red light under the USB mouse does not light up when it is plugged into the bad port. I switched up what was plugged into the ports and it was back to how it was; the headphones did not work and the mouse worked without a problem.

    So the only conclusion that I could draw was that one of the ports does not work right. The thing that makes this situation particularly weird is the fact that my previous headphones were able to work with the bad port without a single problem.

    I have tried resetting the PRAM and the SMC, but I had no success with that. Although I am not sure if I did those right.

    Has anybody had a similar problem before? I would really appreciate it if you could help me out with this one. Thanks a lot!
     
  2. RegulusRises macrumors newbie

    Joined:
    May 27, 2012
    #2
    Did the previous headphones using USB and the 3.5mm jack use USB only for power, by any chance?
    My 2011 15" MBP is exhibiting the same symptoms. With no known cause my upper USB port has lost most functionality. I can charge small-draw devices that do not require data, but I cannot use the port for anything else.
    I have not yet tried rebooting or resetting PRAM, but only due to laziness. I'll try that and then edit this post.

    When I plug things in that require data to function I usually see a brief supply of power, and then the port turns off. Things like my USB mouse blink and then go inert. This is not accompanied by an over-draw warning from the OS, or an error in the console. I have not tried probing with a scope or a logic analyzer, but I don't expect them to be very enlightening.
     

Share This Page