Only want to view PDF files, not download all of them.

Discussion in 'Mac Basics and Help' started by Kendo, May 28, 2011.

  1. Kendo macrumors 68000

    Apr 4, 2011
    Hey guys. I've had my iMac for a week now but I can't seem to figure out how to view PDF files and not have them downloaded every time.

    If I click a link to a PDF on a website, I always select open but it also downloads into my Downloads folder which can be a pain having to delete them every so often. Is there a way to prevent this?

    Also, do people here rely on Preview to view PDF files or do you download Adobe Reader?
  2. cantthinkofone macrumors 65816


    Jul 25, 2004
    Missouri, USA
    I would like to know this as well. I never ran into the problem but I know a few people who had the same problem as you. I could never figure out how to change it. Mine always open up in a browser window and allows me to download it or just view it.
  3. Dave Felix macrumors 6502a

    Dave Felix

    Apr 9, 2011
    Scranton, Pennsylvania
    send me a link with a PDF file linked to it. I want to try and see if it also happens to me. Even if you right click and open and still downloads??
  4. Jeanne-W macrumors newbie

    Jun 12, 2009
    Orlando ~ close to the mouse
    Hope someone has an answer to this too. I remember preview automatically opening pdf files so you can view them... now they go to my download folder and have been for some time now and I don't know why. I went to preferences in preview to see if a setting there but couldn't find one, I also checked FF preferences but nothing there either. :(
  5. Kendo thread starter macrumors 68000

    Apr 4, 2011
  6. Hugh macrumors 6502a


    Feb 9, 2003
    Erie, PA
  7. Tumbleweed666 macrumors 68000


    Mar 20, 2009
    Near London, UK.
    I've just gone to the McD website, in Firefox the pdf downloads, whereas in Safari, it doesn't. So, its a Firefox behaviour. I can't find anything in preferences to stop it.
  8. Kendo thread starter macrumors 68000

    Apr 4, 2011
    That must be it. I'm using Firefox.

Share This Page