Opera browser brings beachballs when typing

Beachguy

macrumors 65816
Original poster
Nov 23, 2011
1,008
407
Florida, USA
I installed Mojave 10.14.2 beta 4 on Friday (and now GA Mojave 10.14.2), and now when I use it to enter text on a website, I get beachballs like crazy every time I type in anything. No other application has this problem. I reinstalled Opera (both beta and general release) and also turned off extensions and it did not fix the problem. Any suggestions? Is anyone else experiencing this?

Added- I also updated the Opera Browser to a newer version, and I still have that problem. I tried posting this on the Opera website and got no response, so I am hoping here there will be some ideas. I did NOT have the problem on beta 3, and did not update the Opera version until a few days after the beta 3 to beta 4 conversion.
 

Beachguy

macrumors 65816
Original poster
Nov 23, 2011
1,008
407
Florida, USA
I'm hoping someone has suggestions- even just informed guesses. Migrating browsers is a real pain!!!
 

Big Ron

macrumors 6502
Dec 7, 2012
365
62
United Kingdom
Have you tried creating another user account? If the problem exists within the second user account you at least will know it isn’t your current account.

If it doesn’t try another browser, I find chrome works ok.
 
  • Like
Reactions: Beachguy

Beachguy

macrumors 65816
Original poster
Nov 23, 2011
1,008
407
Florida, USA
I did sign in on another profile and did not experience the beachballs, but I am simply not sure what and where to look beyond disabling the extensions.
 

Big Ron

macrumors 6502
Dec 7, 2012
365
62
United Kingdom
I did sign in on another profile and did not experience the beachballs, but I am simply not sure what and where to look beyond disabling the extensions.
You could drive yourself banzi trying to get to the bottom of it. Cut your losses and slowly reinstall apps into your known working account, monitor after each app, and when you have a stable system delete the original account.
 
  • Like
Reactions: Beachguy

Beachguy

macrumors 65816
Original poster
Nov 23, 2011
1,008
407
Florida, USA
With only the one browser having problems, I'm just moving to a different browser until it clears up.
I cleared cache and cookies, reinstalled, had updates to both the browser and the OS to no effect.

I'll just keep hanging in for now.
 

Similar threads

  • myitrumors
5
Replies
5
Views
506
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.