Original iPhone: "me" keeps correcting to "mr"

Discussion in 'iPhone' started by TheSpaz, Jun 29, 2009.

  1. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #1
    On my girlfriend's first generation iPhone running 3.0, the dictionary keeps correcting the word "me" to "mr" for some reason and no matter how many times you tell it not to, it still does it. I have even reset her Keyboard Dictionary in Settings>General>Reset

    I've also tried restoring her iPhone and re-jailbreaking it with Redsn0w (She's hacktivated).

    Does anyone else have this problem?
     
  2. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #2
    Sounds like she has a "Mr ___" in her address book. Get rid of it there, and it should stop auto-correcting. ;)
     
  3. techfreak85 macrumors 68040

    techfreak85

    Joined:
    Jan 13, 2008
    Location:
    Places
    #3
    Arn payed Apple to haveit turn to MR as subiminal advertising. :rolleyes:
     
  4. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #4
    You know what... that's a really good point. I shall check that. Thanks!

    PS: I feel so stupid that I forgot about the address book :(

    EDIT: It worked... she had a Mr in her address book. All fixed now. Thanks Mavis... you're not so bad ;)
     
  5. Anuba macrumors 68040

    Anuba

    Joined:
    Feb 9, 2005
    #5
    Ouch, this gives me flashbacks from the days before Apple added the option to disable that god awful feature. It worked fine for monolingual people but was pure horror for anyone who had two or more dictionaries enabled. Mine corrected all my English to Swedish and vice versa. Everytime I tried to enter "att" (the Swedish word for "to"), it was corrected to "AT&T".

    Disable it!!!
     
  6. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #6
    We like auto-correct, but I'm pretty sure normal people type the word "me" more than they type "mr".

    I think that maybe Apple should incorporate automatic grammar correction. So if the sentence doesn't make sense like "What would you like mr to do?" ...it would fix it.
     
  7. kendallspike macrumors newbie

    Joined:
    Sep 15, 2010
    #7
    Thank you so much that was bugging me:D
     
  8. bradhs macrumors member

    Joined:
    Jun 5, 2010
    #8
    I found a better solution! I had the same exact issue, was driving me crazy and I thought there's no way Apple screwed that one up and not fixed it yet. So I kept playing around with my phone book. I noticed that I had a few people in the phone book as "Mr" and not "Mr."

    Simply change your Mr entries to Mr.

    AND your Ms entries to Ms.

    AND GUESS WHAT!? No more issue...!!

     
  9. Shanewilliams macrumors 6502a

    Joined:
    Apr 3, 2010
    #9
    I have the exact same issue with my iPhone 4. I do not have anyone listed as Mr or anything similar in my contacts. Any ideas??
     
  10. bradhs macrumors member

    Joined:
    Jun 5, 2010
    #10
    Maybe in your Notes or Calendar? Try doing a search on your phone for mr and see what comes up.

    Also, make sure Spotlight is setup to search everything on your phone so not to miss anything.
     
  11. iphonecorrect macrumors newbie

    Joined:
    Feb 27, 2013
    #11
    Try the new version of red
     

Share This Page