OS/X Mavericks won't download - Click "Download" nothing happens

Discussion in 'Mac Basics and Help' started by Hiawatha, Oct 24, 2013.

  1. Hiawatha macrumors newbie

    Joined:
    Oct 24, 2013
    #1
    I tried to download OS/X Mavericks through the App Store yesterday. However, I had to leave work before it was done downloading and shut down the machine while it was downloading.

    I assumed I'd be able to resume the download, or start over again later.

    However, now there's no way to get it to download again. When I find OS/X Mavericks in the store, I click on the "Download" link. It asks for my Apple ID which I enter, and it does absolutely nothing. It doesn't begin downloading, and it just still shows the "Download" button. Clicking on it again does nothing.

    I'm thinking there's something stuck somewhere, like some flag that says this download is in progress or it has already been downloaded. Is there some way to clear that out so I can start downloading it again?

    PS - I'm currently running OS/X 10.7.5
     
  2. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #2
    Look in the Purchased tab. You might find a resume button.
     
  3. ajm200500 macrumors newbie

    Joined:
    Oct 31, 2013
    #3
    still wont ****ing work

    well now im straight up pissed off. i tried clicking the download button under purchases, and when that didnt work i tried clicking the x to delete the download all together. that didnt work either, as now the download is still there AND the button went blank and says nothing… **** YOU APPLE, I HOPE SOMEONE SHOOTS TO DEATH WHATEVER DICKFACE (POORLY) DESIGNED THIS ****** EXCUSE FOR A PIECE OF SOFTWARE
     
  4. imurdaddy macrumors member

    Joined:
    Nov 6, 2012
  5. firedept, Oct 31, 2013
    Last edited: Oct 31, 2013

    firedept macrumors 603

    firedept

    Joined:
    Jul 8, 2011
    Location:
    Somewhere!
    #5
    Why so angry? Time to grab a coffee, maybe a smoke, and definitely get your medication going. Way to early for this kind of anger.

    You can try signing out of App Store and signing back in. I had a problem getting it to start and this finally worked for me. Worked for some others on here as well.
     
  6. Tyler23 macrumors 603

    Tyler23

    Joined:
    Dec 2, 2010
    Location:
    Atlanta, GA
    #6
    First off, might be time to relax.

    Now, try these two things.

    1) Open Launchpad, and then try clicking on the Install Mavericks app. See if this will restart the download.

    2) If that doesn't work, hold down on the icon (like you would on an iOS device) until the icons wiggle, then delete it by clicking the X. Then try re-downloading from the Mac App Store.
     
  7. scarduner macrumors newbie

    Joined:
    Feb 1, 2011
    #7
    Launchpad worked for me

    Thanks for the tip and just letting others with this problem know that my download was paused when I found it in Launchpad. Not very helpful feedback from the process in the App Store - no notice that the download began, that it was paused....
     
  8. Mr Frodo, Jun 28, 2014
    Last edited: Jun 28, 2014

    Mr Frodo macrumors newbie

    Joined:
    Jun 28, 2014
    #8
    Been trying to download OS X Mavericks and came across this tip by Tyler23 the icon would be on the application screen with 'waiting' under icon and nothing was happening.

    Hey guys great!! the above tip worked for me. Thanks
     

Share This Page