OS X Mountain Lion 10.8.3 Stuck on American English Language Spelling

Discussion in 'Mac Basics and Help' started by interfuse, Mar 26, 2013.

  1. interfuse macrumors member

    Joined:
    Dec 18, 2006
    #1
    The system wide spell checker for my OS X 10.8.3 install spell checks everything based on American English. How ever, in System Preferences I have it all set to Australian English.

    As you can see with the attached screenshot, system applications such as Mail are doing spell checking based on American English.

    Is this a bug? Am i missing something? I have changed to Aus English in System Preferences> Language & Text > Language bar & Text bar.
     

    Attached Files:

  2. interfuse thread starter macrumors member

    Joined:
    Dec 18, 2006
    #2
    System Preferences:
     

    Attached Files:

  3. Nermal, Mar 26, 2013
    Last edited: Mar 26, 2013

    Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #3
    Stupidly, choosing a non-US English in System Prefs won't actually fix the spellchecker. Instead of choosing Australian English, choose Set Up and then turn off US.
     
  4. interfuse thread starter macrumors member

    Joined:
    Dec 18, 2006
    #4
    I went to Set Up... and only Australian English was ticked already.
     

    Attached Files:

  5. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #5
    Huh. In that case, I don't know what to suggest. I just tried Australian (I usually have mine set to British) and "colour" was detected as correct (and "color" as incorrect) so I don't know why it's not working for you.
     
  6. interfuse thread starter macrumors member

    Joined:
    Dec 18, 2006
    #6
    No worries, thanks anyway.

    I might try the good ol' Apple Discussion forums lol.
     
  7. Guldsmed macrumors newbie

    Joined:
    Mar 26, 2013
    Location:
    Tasmania
    #7
    Americanlish

    Just a passing thought, have you shut down and re-started?
    Mine is in Aust. English and works OK.
    Also, what word processor are you using ? Some have a setting in the preferences about using system language etc. etc.

    Good luck
     
  8. interfuse thread starter macrumors member

    Joined:
    Dec 18, 2006
    #8
    i reset P-RAM, repaired privileges, and also checked the .GlobalPrefernces file where it saves what language etc are selected..

    still no good!

    Apple's solution is to re-install the OS!

    surely there's a file somewhere that's getting in the way. i'm determined to keep looking.

    Thanks for all ya'll help anyway.
     
  9. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #9
    Reinstalling won't do anything for a preference setting. Nor will PRAM or Repairing Permissions.

    I use the following defaults command to set British, which you will need to adapt for Strine. :p
    Code:
    defaults write -g NSPreferredSpellServerLanguage "en_GB"
    
     
  10. jonutarr macrumors regular

    jonutarr

    Joined:
    Sep 1, 2006
    Location:
    OZ
    #10
    I have this problem also since I upgraded to Mtn Lion, all apps are in US & A language :mad:
     
  11. colourfastt macrumors 6502a

    colourfastt

    Joined:
    Apr 7, 2009
    #11
    Didn't you know that the Yanks rule the world?
     

Share This Page