OSX 10.14 Mojave broken and unusable on 27" Late 2013 iMac with 3TB Fusion Drive

Discussion in 'macOS Mojave (10.14)' started by Aedant, Sep 30, 2018.

  1. Aedant macrumors newbie

    Aedant

    Joined:
    Sep 30, 2018
    #1
    I'll try to make this short and organized.

    TLDR: installed Mojave twice, one time less than perfectly and on time after completely wiping my computer, and both times, it took about 10 minutes to boot, had a hard time connecting bluetooth keyboard and mouse, the wi-fi symbol had a X and said there was no hardware (so impossible to use), and everything was unbearably slow. Completely unusable. Here are my computer specs :

    [​IMG]

    [​IMG]

    [​IMG]

    Full story :

    On Thursday I wanted to install Mojave on my mac. I downloaded the software and proceeded to the installation. At some point, it told me that "Mojave could not be installed on this computer". I found it weird, so I cancelled the download. But then I decided to try again. No message this time.

    The Mojave installer was working, and soon restarted. The Black Screen with apple logo and loading bar appeared and everything seemed to go well. The bar then stayed stuck at about 60% with the message "calculating time remaining". I decided to leave my house and come back when it would be completed. I came back 3 hours later, AND THE BAR WAS STILL STUCK at the same place. I left it for an hour more. I didn't move. So I decided to unplug the computer.

    It restarted in a boot loop, until it started on the Bootcamp side, where the was only a blue screen saying "REPAIR YOUR PC". SO I put my mac in recovery mode. I then procedeed to reinstall Mojave from there. That time, it completed the installation. It finally booted "normally", but it took FOREVER to get to the password screen. About 15 minutes.

    Then, it took me about 6-7 minutes to get the bluetooth mouse and keyboard working. Then, I clicked on my profile, and it took another 4 minutes so that my profile picture would get to the center and the text box would appear. Then I FINALLY managed to log in. Once logged in, the computer was "working". I could move my mouse freely, select folders, etc. But every time I would actually open something, it would take ages. The wifi had an X over it and said " no hardware found". In the network preferences, it took about 6 minutes for the menu items to appear. I plugged an Ethernet too, and none of the connexions would work. It was also impossible to make an external hard drive work. I managed to get them connected for 10 seconds at most from the Disk Utility.

    As suggested online, I reseted PRAM and SVC, to no avail. No changes at all. I started in safe mode. Nothing. I did this for quite a while, before finally deciding to wipe my iMac entirely and start again. So I went in internet recovery mode and in Disk Utility. There, it told me that my drive was no longer FUSION, and that it had to be reassembled. I said yes, and then proceeded to reinstall Mavericks. It went perfectly. Quick and everything. From Mavericks, installed High Sierra. No problems. Wifi and everything. Then made a migration from my Time Machine. No problems at all, everything had come back to normal.

    I wondered if the fact that I had disconnected the computer while installing had caused all these problems, so I figured I could reinstall Mojave from scratch and see.

    But, ALL the same problems reappeared. 10 minutes booting time, broken bluetooth, no wifi, unbearably slow. Had to to all the process again to get back to where I was with High Sierra.

    SO, do you guys think I did something wrong somewhere? Should I have prepared my mac in any way before? It's still quite a powerful iMac, I don't see why it wouldn't support it!

    Thanks!
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    I'll make my reply short and organized:
    Have you considered "going back" to High Sierra...?
     
  3. tmcnulty1381 macrumors newbie

    Joined:
    Aug 29, 2010
    Location:
    Eastern Massachusetts
    #3
    I had the Apple Store erase and install HS over multiple install of Mohsve at home and at
    The Apple store ( 3 hours worth).
     
  4. Aedant thread starter macrumors newbie

    Aedant

    Joined:
    Sep 30, 2018
    #4
    Well, i reverted to High Sierra for the second time, and now planning to wait until Mojave is usable. But I just wonder what the problem might be, since my computer is not supposed to be already obsolete, and Mojave is compatible with late 2012 iMacs...
     
  5. PLin macrumors 6502

    Joined:
    Oct 9, 2003
    #5
    I couldn’t even get Mojave to install on my 27-inch Late 2013 with 3TB Fusion Drive. First, it said Boot Camp wasn’t supported on my computer even though Apple’s support document says only the Late 2012 model with 3TB is affected. So I removed my Boot Camp partition, and the Mojave then gave me a different error that it couldn’t preflight the APFS conversion.

    When I used Terminal to do a “diskutil list”, I noticed that even though my drive was a single 3.12GB partition, there were 2.2GB and 800GB slices with a 650MB Recovery partition sandwiched in between.

    I ended up backing up everything, using the Terminal to delete the slices and make a single partition, and restoring everything. Mojave install completed, but Boot Camp Assistant couldn’t create the Boot Camp partition. To fix that problem, I found a forum lost that suggested removing any Time Machine Local Snapshots. That actually allowed the Assistant to create the partition. The weird thing is that I chose 130GB and ended up with a 250GB partition.

    There are definitely some bugs to work out for Mojave/Fusion Drive/APFS/Boot Camp configurations.
     
  6. mogens macrumors regular

    Joined:
    Jan 24, 2010
    #6
    I installed Mojave on my 27-inch Late 2013 with 3TB Fusion Drive (El capitan and update from appstore) and everything went smoothly (system storage now reports 3,12 TB Fusion Drive).
    It runs like a dream now. Only problem I had was slow startup because I forgot to update Little Snitch to latest version (4.2), before the upgrade.
    I run Bootcamp from an external USB3 SSD disk.
     
  7. interstella macrumors regular

    interstella

    Joined:
    Sep 29, 2013
    Location:
    Suffolk, England
    #7
    The OP's experience is very similar to my own, also with a late 2013 iMac. I eventually succeeded in installing Mojave from a USB drive. Nothing else would work. Took a long time but the iMac has been fine ever since.

    I had no problems whatsoever with my late 2013 MacBook Pro and Mojave installed on this very quickly. Am I right in thinking that fusion drives seem to be the main cause of problems with installing this OS? It seems that some are fine but there's a considerable number of fusion drives that have problems with installation.
     
  8. Aedant thread starter macrumors newbie

    Aedant

    Joined:
    Sep 30, 2018
    #8
    Hey guys, I have an update!

    So, after chatting with apple support, I decided to try another way of installing Mojave, to try to pinpoint the issue. So instead of wiping, then installing Mavericks, then High Sierra, then Migration and THEN Mojave, I went into cmd-opt-R recovery mode.

    I wiped my entire drive again, and directly convert to APFS from Disk Utility. Then, from internet recovery, I DIRECTLY installed Mojave, without my files on anything. And It worked! Mojave was fast, going smoothly, no wifi problems, applications worked. I then figured that I would migrate my files from there.

    So I used my Time Machine to migrate everything, but since I read that “computer and network settings” could potentially pose problems, I ticked them off. Once the migration finished, evertyhing was in place, but a weird message appeared : “ OSX can’t find your home folder or it is not in it’s usual place”. My home folder was accessible in my “favourites” in finder, but for example, in the GO menu, it was greyed out. So I figured that the path was somehow disconnected. Appart from that, all my files had migrated, the WiFi was working, the experience was generally going smoothly, but a few apps didn’t really work ( probably because of the issues with the home folder ), for example the adobe suite was impossible to open.

    I figured the issue would then be resolved maybe by restarting. So I restarded. And then, catastrophe. 15 minutes booting time. Ultra lag everywhere. Hard time finding the bluetooth. No wifi hardware. No external hard drives. Every single problem came back.

    SO, the real problem lies somewhere in my home folder. For sure. I decided, again, to revert to High Sierra for my computer to be usable. I’ll wait for some time before trying again to upgrade, because it is VERY time consuming...
     
  9. rcoden macrumors newbie

    rcoden

    Joined:
    Aug 29, 2014
    Location:
    Virginia Beach
    #9
    Looks like I have a mirror image iMac as Aedant (same CPU, ram, fusion drive, minus the Bootcamp partition) and I've had ZERO issues with Mojave. Did an upgrade, no issues, did a clean install off a USB stick last night, no issues. Think Bootcamp was documented as having issues with 3TB Fusion drive in past release notes.
     
  10. KennyB123 macrumors newbie

    Joined:
    Sep 21, 2016
    #10
    I have exact same problem as the OP on my late 2013 iMac with SSD( no fusion drive). Ended up restoring High Sierra from Time Machine. I’ll wait a few months before trying Mojave again with hopes that Apple will get it fixed.
     
  11. Don Brooks, Nov 3, 2018
    Last edited: Nov 7, 2018

    Don Brooks macrumors newbie

    Joined:
    Nov 3, 2018
    #11
    Does anyone have a thought as to when they might fix this?
     
  12. jdw13 macrumors member

    jdw13

    Joined:
    Oct 2, 2015
    Location:
    Boston, Maine, Chile
    #12
    I, too, have iMac (27-inch, Late 2013) but with 1TB Fusion drive and 16 GB RAM.
    Is it clear that the problem is only with installs with a Bootcamp partition?
     
  13. Don Brooks, Nov 6, 2018
    Last edited: Nov 7, 2018

    Don Brooks macrumors newbie

    Joined:
    Nov 3, 2018
  14. Don Brooks, Nov 6, 2018
    Last edited: Nov 7, 2018

    Don Brooks macrumors newbie

    Joined:
    Nov 3, 2018
    #14
    Restoration of previous system did not solve response issue
     
  15. Don Brooks, Nov 7, 2018
    Last edited: Nov 7, 2018

    Don Brooks macrumors newbie

    Joined:
    Nov 3, 2018
  16. jazzsims macrumors newbie

    jazzsims

    Joined:
    Nov 22, 2017
    #16
    I had serious problems after installing High Sierra on my iMac (27-inch, Late 2013) - same configuration as OP, so had to wipe my Mac and reinstall Sierra, then rescue all my 'stuff' with Time Machine!
    After reading above, I think I'll wait till the dust settles before I consider Mojave....
     
  17. jerwin macrumors 68020

    Joined:
    Jun 13, 2015
    #17

    well, I've got a 2014 imac 5k, and my problems started with mac osx 10.14's latest update.
    i had a bootcamp partition, but since I use an External ssd for that, Ideleted it in one of my vain attempts to get my system back in order.

    doesn't even boot now.

    internet recovery wants to install something really old.
    I thought that verbose mode might help, but it ignores that key. so now I'm trapped in that apple "it just works(except when it doesnt) mode.

    I'm hosed. This is my primary machine, and my other devices are next to obsolete.
     
  18. oscarodas macrumors regular

    Joined:
    May 7, 2013
    Location:
    Sydney Australia
    #18
    I have Mojave on my imac 27 2014 retina, 3tb fusion drive never had a problem, by the way I also am enrolled in the beta program, and never had a kernel panic.
     
  19. jerwin, Nov 9, 2018
    Last edited: Nov 9, 2018

    jerwin macrumors 68020

    Joined:
    Jun 13, 2015
    #19
    Well, if you ever need to get your imac back in order, if something does happen, you need to install Mojave *first* and then migrate your time machine data, as if you were moving to a new machine.
     
  20. TinHead88 macrumors regular

    TinHead88

    Joined:
    Oct 30, 2008
    #20
    It sounds like the migration is the issue. Could you move your data and reinstall apps instead? iCloud makes a clean install with manual data migration much easier these days.

    For reference I have the same iMac and had no issues at all with Mojave.

    upload_2018-11-10_21-13-6.png
     
  21. davidbod macrumors newbie

    Joined:
    May 4, 2019
    #21
    I have had a similar issue over the last several weeks, iMac Late 2013 3 TB Fusion. It has been running Mojave for a while. Back in Oct 2018 I installed a bootcamp Windows 10 partition. Everything ran fine until some time after the 10.14.4 update came out. It just one day started beach balling like crazy. App startups were ridiculously slow, any menu for an app took way to long to come up, and typing into menu windows was so slow like 1 or 2 characters at a time with beach balling in between. When I went to reboot it took an hour for it to come back up.

    After spending days on the phone with Apple Support we ended up getting rid of bootcamp, reformatting everything and re-installing Mojave. After all of that no luck same issues. So I decided to just go back to HFS+ and High Sierra and the iMac is now running fine. It's a pity Apple changed the way OS is downloaded now, as I couldn't just go back to Mojave 10.14.3. The only available full install of Mojave is 10.14.4 and that's it.

    I don't know for sure if it is just 10.14.4, but it is probably at least a contributor. I suspect that this also has something to do with APFS and older drives. Before I went back to High Sierra I purchased Drive Genius 5 to do a full scan of my drives. It showed the SSD as fine, but was showing a consistent error on the HDD within the first 10 minutes of the scan at the same place over several tests. Erasing / reformatting the drive under APFS didn't fix it.

    In the process of going back to High Sierra you have to break the Fusion which reformats both drives automatically back to HFS+. Testing the drives now with DG5 showed no issues. I tried at this point to go back to Mojave with an APFS Fusion drive, and it was better, booted much faster almost normal, was useable as a computer but still frustrating beach balling. Going back to High Sierra it is completely normal running as well as the day I got it.

    If I get some time I would like to install Mojave on a mule drive and do a bit-for-bit copy back to the iMac running HFS+ Fusion. I have seen where people have done this to avoid APFS under Mojave. This would be a painful process though, as every time an update comes out you have to do the update on the mule drive and then do a bit for bit copy of that back to the Fusion drive, many hours.

    It would also be great to find a full install copy of Mojave prior to 10.14.4. I have searched but no luck.
     
  22. treekram macrumors 68000

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #22
    People on various forums here have been reporting issues with 10.14.4 and fusion drives. If the full scan of the HDD shows an error at the same place, you should see if Drive Genius 5 (I'm not familiar with the package) can mark the sectors as bad. Otherwise if you don't do something so that the OS avoids using those sectors, you'll have problems when you write to those sectors - or you can just junk the HDD.
     
  23. mrdunderhead macrumors member

    mrdunderhead

    Joined:
    Jun 14, 2015
    #23

    Actually this is simple Mac OS X mojave requires the hard drive to be formatted in APFS to receive system updates not Mac OS X extended journaled
     
  24. davidbod macrumors newbie

    Joined:
    May 4, 2019
    #24
    I am suspecting that this is the core problem. I think there are issues with APFS properly communicating with the lower level drive in marking bad sectors / blocks, or it just doesn't have this capability. As soon as I went back to HFS+ reformatting, the bad sector got removed. I tried many times to reformat erase under APFS and it did nothing leaving the bad sector as is.

    As a drive ages it will start developing bad sectors and HFS+ seems to be able to remove these where APFS does not. Keep in mind Apple designed HFS+ for hard drives and they designed APFS for solid state drives.

    The older non beveled edge iMacs were much easier to work on, just pull the screen off which is held by magnets and away you go. The new ones it's a PITA as the screen is more like glued on. For now I think the easiest solution is to just downgrade to HFS+ High Sierra until the drive goes completely bad.
    --- Post Merged, May 5, 2019 ---
    Just so everyone knows you can "put" Mojave on a HFS+ Fusion drive, but it's a long process. You need a dedicated external mule drive which would be APFS and bootable with Mojave installed. When a Mojave update comes out you have to boot to this drive and do the update there. Then use something like Carbon Copy Cloner to clone the mule drive back to the iMac HFS+ Fusion drive. I haven't tried this yet myself, but I have seen where others have done this.
     
  25. davidbod macrumors newbie

    Joined:
    May 4, 2019
    #25
    One more step if you decide this. You first have to update the mule drive with everything on the iMac or you will lose your personal data and installed programs etc., basically anything that has changed since the last time you updated the mule drive.

    I tried this today on my late 2013 iMac:

    1. Clone the iMac internal Fusion drive to the external mule drive
    2. Boot from the mule drive to make sure it is all OK
    3. While booted from the mule drive, break the iMac internal fusion drive and then rebuild the fusion but HFS+
    4. Clone the mule drive back to the iMac internal Fusion drive that is HFS+

    When I did this, first after step 2 when booting from the external drive it ran fine no slow downs or lags except when the external drive was being accessed. When I booted after step 4 the iMac behaved very well, no slows or lags at all.

    I'm going to leave it like this for a while and see how it behaves, but so far so good.
     

Share This Page

25 September 30, 2018