OSX 10.14 Mojave Fusion disk broken and unusable on 27" Late 2013 iMac with 3TB Fusion Drive

Discussion in 'macOS Mojave (10.14)' started by rcvd, Jan 9, 2019.

  1. rcvd, Jan 9, 2019
    Last edited: Jan 9, 2019

    rcvd macrumors newbie

    Joined:
    Jan 9, 2019
    #1
    While working on my Late 2013 3 TB Fusion iMac for only 5 minutes after waking it, it started slowing down while opening an application, which made me try to reboot. The reboot failed showing the infamous STOP sign.
    I was running MacOs Mojave 10.14, very recently upgraded, not exactly sure when.
    I managed to recovery boot using my Time Machine backup disk, and went in to Disk Utility. Problem was that the SSD showed but the Macintosh HD was invisible, not listed at all, no disk of a size near 3TB at all.
    I then created a USB boot stick using the Mojave Installer software and booted with that. When selecting Disk Utility, Macintosh HD was shown but greyed out. I tried the REPAIR option but it came back with an error which unfortunately I did not record.
    I then tried the Fusion repair instructions by Apple using Terminal and the results of those actions are in the screenshots below. In short I tried to recreate the Fusion disk which did not work and came back with this error:
    'Your computer must have exactly 1 solid-state and 1 rotational disk drive'. I then tried the manual commands which lead to unmounting of disk0 (ssd) and disk2 (Mac HD). But now I am unable to remount disk2, using standard commands. Are there any signs my HDD has failed, or is this caused by the OS creating problems with APFS file systems on SSDs? I've restarted with the same Mojave boot disk I created but the Macintosh HD is not shown anymore.
    Clearly I am not an expert, which is why I am posting here to hopefully do further troubleshooting and determine the core of the problem, and then hopefully a solution!
    All inputs massively appreciated.
    (one thing that caught my attention, the list command in Terminal lists the SSD as internal physical, but for the Macintosh HD the description shows 'synthesized'. Should this not be physical as well? Does it mean the physical disk is not found any longer ie disk failure?)
    Screenshots of my actions in Terminal are attached below.
    I should have all data in my Time Machine backup. I would be more than happy to go back to High Sierra or earlier if that gets the Machine running again..!
    ** edit: I've read similar threads to this which were very useful but now feel I need specific help, so I started a new thread, hope that's ok!
     

    Attached Files:

  2. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #2
    If you have a 10.14.2 installer (which is what you should get when you use internet recovery at this point) you can now use this command:
    Code:
    diskutil resetFusion
    This is new to 10.14.2, and it'll reset the disks to create a single Fusion volume. It will erase all data on both the SSD and the internal drive, so if you have anything of importance on the disks at all (such as a second partition) you will lose it if it's not backed up.
    See here: https://support.apple.com/en-us/HT207584

    Edit: It looks like the 3TB disk may have failed completely, which is why none of the repair options worked.
     
  3. rcvd thread starter macrumors newbie

    Joined:
    Jan 9, 2019
    #3
    Thanks for the reply! I've used this command and the results are in the attachment below.
    In short it looks to me like it erases and partitions fine but then encounters an error writing to the HDD. I saw the partitioning progress come to 50% for the HDD, but then the following message is displayed: 'Error: -69760: Unable to write to the last block of the device
    Could not perform or finish the operation: -69760 (Unable to write to the last block of the device).
    Screenshot of the Terminal commands and outputs is attached.
    I suppose the HDD has failed, or is there anything else to try?
     

    Attached Files:

  4. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #4
    Open Disk Utility from Recovery and make sure "Show all devices" is selected from the View menu. If you don't see the disk there then you'll easily be able to tell it's dead.
     
  5. schlotz macrumors member

    Joined:
    Dec 11, 2012
    #5
    Assuming for the moment that the HDD is toast. You will have a choice to make. A number of third party Apple licensed repair shops can replace the HDD. Personally, if going that way I would opt for just putting in a 500Gb SSD which will make your 2013 iMac faster (IMO the fusion solution was never a great solution). Then attach and external drive of any size you want.

    OR, just attach a large external HDD and boot from that. Obviously the 2nd option will be cheaper.
     
  6. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #6
  7. vkd macrumors 6502a

    vkd

    Joined:
    Sep 10, 2012
    #7
    HDD is dead, unfortunately. Cheapest and quickest solution is to format the SSD and install the OS on it and buy an external USB3 HDD, using that for storing all your data.
     
  8. rcvd thread starter macrumors newbie

    Joined:
    Jan 9, 2019
    #8
    Thanks everyone for the inputs. The replacement program is interesting. But indeed clearly too late for me. I don't think the method of checking the serial number is open anymore, and I suppose the replacement program ended anyway.
    After trying all suggestions obviously the HDD is dead. I did manage to re-install Mojave on the SSD drive only. I am probably going to replace the internal HDD with another SSD. Now I just have to decide whether to ultimately install the OS on the smaller or on the bigger SSD. Are there any recommendations for optimum system performance? I know it is important to keep plenty free space on the drives to keep the OS working properly, so would the original approx 120 GB SSD be fine for that or would it be better to re-install on the new larger SSD?

    Also, on waking the iMac from sleep I can hear very weak sounds that must come from the HDD, it seems the system still searches it first.. It takes the clean Mojave install about 15 seconds to wake up.. Would that be normal behaviour? Before the crash of the HDD the wake-up time was much shorter..
     
  9. vkd macrumors 6502a

    vkd

    Joined:
    Sep 10, 2012
    #9
    Yes, its repeatedly trying to initialise the drive and failing, then on time out it registers the last known response (dead) and moves on.

    Regarding size, only you can answer that. How much data have you got backed up? How much space do you need? If you have 600GB of data and don't generally go much above that then a 1TB drive would work. If you have 300GB of data then a 500GB drive would work, etc. As I said before the smart option is using an external drive. That way you don't have to risk opening the glued-on screen or paying someone else to do it. You could get an external SSD or even get a Thunderbolt drive. You can easily fix a small ext. drive to the back of the stand with rubber bands or tape, etc. if it bothers you to see it. It won't slow performance down and best of all, in my opinion its cheap and cheerful.
     
  10. rcvd thread starter macrumors newbie

    Joined:
    Jan 9, 2019
    #10
    Yes for my data I have various disks to keep those on, I'm thinking of the drive with the OS on. It's now on the remaining internal SSD of 120 GB. The OS itself, Mojave, only seems to take 13 GB. I suppose it's obvious it's more than big enough. All depends on how many applications I will be installing..

    Can I trouble you all with one more thing, when I boot up the iMac I get the message 'the disk you inserted was not readable by this computer.' I have no external drives or USB sticks or memory cards or Thunderbolts connected. I can then click on Initialise and Disk Utility opens up as shown as below in the image. I have the option View All Devices enabled here. I can clearly see the SSD. Then there is another disk showing with a size of only 4GB. Would this be a remnant of the 3TB HDD? Where does it come from? As you may notice I am not exactly sure how Disk Utility would show separate physical drives or partitions..? Many thanks!!
     

    Attached Files:

  11. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #11
    "Would this be a remnant of the 3TB HDD? Where does it come from?"

    I believe the answer is "yes".
    The OS -- once booted -- has found the [damaged] internal HDD, cannot read it, and is giving you the report you see.

    For now, I think the correct response will be to click the "ignore" button, and then go about your business "as if it wasn't there".
     

Share This Page