OSX 10.3.7 sees CDS but not DVDs on PIONEER DVD-RW DVR-107D

Discussion in 'Macintosh Computers' started by G-UK, Jan 7, 2005.

  1. G-UK macrumors newbie

    Jan 7, 2005

    I/m sure that there are many Mac users out there who are far more'clued up' on these DVD/rws, than me, so I someone can help with this one.

    Computer: G4 450 dual processor
    OS: 10.3.7
    I have replaced my original DVDR/CDR (actually a Hitachi Model GD-7000 DVD-ROM, with the a PIONEER DVD-RW DVR-107D. My system profiler recognises it as follows:
    Manufacturer: PIONEER
    Model: PIONEER DVD-RW DVR-107D
    Revision: 1.15
    Drive Type: CD-RW/DVD-RW
    Disc Burning: Apple Supported/Shipped
    Removable Media: Yes
    Detachable Drive: No
    Protocol: ATAPI
    Unit Number: 0
    Socket Type: Internal

    It recognises and reads CDs. However, when I try to run a dvd, ie Apples iLife installer DVD, or a pre-recorded DVD the drive ejects it after a couple of minutes inactivity.

    I have loaded Patchburn 3 which tells me "The selected CD/DVD writer is also supported by Mac-OSX. No need to patch anything!

    I have tried the jumper in a couple of different positions. Would it work in slave position?

    I am about to purchase Toast 6. I have not tried burning acd from the drive. Having just written that, I think I will reboot in OS9 and see if Toast 5.2 will burn a disc.

    In short; can you tell me how to get my Mac to recognise and read/write a DVD.

    Thanks in anticipation of your help. :confused:
  2. Lord Blackadder macrumors G5

    Lord Blackadder

    May 7, 2004
    Sod off
    I had the exact same problem on my Dual 533 when I swapped out its CD-ROM for the DVR-107D. In my case, I was able to boot from my OS X install DVDs (a retail copy of 10.3) and reinstall OS X, after which everything worked fine. I think that an OS reinstall is the only way to get the proper drivers installed.

    I have since upgraded Panther to 10.3.7 without issues, although I ignored the "Apple Super Drive Update" in Software Update since it doesn't pertain to this drive.
  3. G-UK thread starter macrumors newbie

    Jan 7, 2005
    Pioneer DVD R/W

    Thanks very much for your amazingly quick help. Unfortunately, I have just spent the last hour or so installing from my odiginal Panther discs, sadly to no avail. Perhaps this is because I opted (rightly or wrongly?) to preserve my settings during installation in order to avoid losing my address book and internet configuration. So it's back to square one for now.
  4. Gokhan macrumors 6502a

    Oct 7, 2003

    had the same problem on my ti powerbook

    start up from osx cd and delete in disk utility your dvd-r drive and reinstall osx should sort ur problem out

    if not you may hav to delete harddisk and dvd in disk utility and do a clean install !!!

    good luck
  5. Lord Blackadder macrumors G5

    Lord Blackadder

    May 7, 2004
    Sod off
    Worst-case scenario: back up your data and reformat the hard drive, then reinstall OS X. I don't think you will have to do that, though.

    You might try what Gokhan suggested with the DVD drive (never tried that myself). You have the option of opening Disk Utility while in the installer. Saving your settings shouldn't affect hardware drivers (though I'm not 100% sure on that).

    I'm convinced that it's a driver issue, since your machine is so similar to mine.

    Good luck!

Share This Page