OSX10.4.7 upgrade to 10.4.11 refuses to accept any log in password!

Discussion in 'macOS' started by mambo66, Jan 4, 2009.

  1. mambo66 macrumors newbie

    Joined:
    Jan 4, 2009
    Location:
    Hong Kong
    #1
    Looking for some insight or help regarding a Mac OSX 10.4.11 problem.

    The scenario:
    Updated a friends Mac Mini from the original operating system it shipped with (OSX 10.4.7) via the Software Update under the Apple menu to a newer version of OSX 10.4.11

    note: OSX 10.4.7 to OSX 10.4.11 means it's an upgrade within the Tiger OS alone - so it's not a Tiger to Leopard issue at all.

    The problem:
    It downloaded and installed 10.4.11 and then asked to reboot as normal. Which I did. On reboot it asked for a password as it normally does. So I typed in the password. No dice. Won't open. Under that password or any other password. This particular machine has only ever 2 passwords. But neither will open. The log in window just wiggles and then sits there. Refusing any password entered.

    The attempted solution:

    I then used the original installer CD's that came with the Mac mini (yes they say Mac mini on them) and I can boot from the CD but if I go into the utilities menu and change the password it doesn't have any effect. No matter how many times I've tried... it simply won't have any effect on log in accepting the password.

    I've tried everything I can under the menu's available to me when I boot off the installer CD's. My friend had zero back up strategy in place... there is nothing to restore the HD to... like a slightly earlier archive. The only thing I haven't done is wipe the drive clean and started over from scratch.

    When I run the Verify Disk utility - it fails verification saying 1HFS volume needs verification. When I launch the disk repair it shows errors but wont repair them - noting Missing Thread Record (id=2222198) and Invalid directory item count.

    Under system profiler it does show that it's now running under the updates system 10.4.11 - only it at no times wants to accept any password I put in.:mad:

    Questions:

    1) Can I just mount this HD as an external HD on another Mac via a Firewire cable and copy the data off to another drive and then just wipe it clean and start from zero?

    2) Is there any way I can go into the Firmware and reset the passwords that might work?

    3) I've looked around several of the Mac forums and this doesn't seem to be a common problem. Anyone heard of similar situations when updating system software inside of OSX Tiger?

    4) When I spoke with customer service at Apple they referred me to the agent here in Hong Kong. I rang them and the receptionist said it'd cost me $700 HKD to have them reset the password. Christ. I'm figuring they're going to try and do exactly what I did and charge me the $700 for it. However... does anyone know if they have a way of going in 'deeper' somehow and possibly getting the passwords reset? Or do they just do like the rest of us and boot it off the installer CD's and leave it at that?

    Goes without saying:


    1) I really need to get this Mac up and running and save the data

    2) If you have friends with no back up protocol in place... you don't need enemies. :(

    Thanks in advance for any and all responses.

    Mambo66
     
  2. Cerebrus' Maw macrumors 6502

    Joined:
    Mar 9, 2008
    Location:
    Brisbane, Australia
    #2
    Sorry to hear of your troubles mate.

    With the mac mini, if you hold the "t" key on boot up, it will go into Target Disk Mode (TDM). If you connect the mini to another mac via Firewire, it should hopefully turn up as an external hard drive on the other mac. fingers crossed, you should be able to navigate it, and get the data you need...(The mini will display the FireWire symbol on the monitor so you know your in TDM)

    You could try this: Boot up in single user mode (cmd+s on booting) and type in fsck -fy on the prompt. See what error it returns, if its fixable. You may have to run this command a few times.

    I've had problems where the normal Disk Utility didnt solve something, but running the file system check did.

    Good luck! :apple:
     
  3. mambo66 thread starter macrumors newbie

    Joined:
    Jan 4, 2009
    Location:
    Hong Kong
    #3
    Thanks mate for taking the time to drop this info on me. I will start with attempting the single user mode solution first. If it has no effect after several attempts I will move on to attempting to recover the data via a Firewire connection to the G4 that is here.

    Will update as to the results. Thanks again.

    cheers,
    mambo66
     
  4. mambo66 thread starter macrumors newbie

    Joined:
    Jan 4, 2009
    Location:
    Hong Kong
    #4
    Ok the update on problems...


    1) I logged in in Single user mode - ran alot of code down the screen but wasn't able to fix any of the problems that kept showing up when I tried to verify the disk or repair those same errors (eg. invalid directory count/item count/etc.). I tried the commands posted earlier for Single user mode (fsck -fy)... but to no avail. :(

    Note: worth noting that the S.M.A.R.T. data shows the status of the drive as being verified.

    2) I was able to get the drive into Target Disk Mode (TDM) but the G4 wont show it on the desktop as a mounted volume. It'll only shows under the disk utility on the G4 but there are not any possibilities from there.... no Verify Disk Permissions/Repair Disk Permissions/Verify Disk/Repair Disk. None of it.:(


    Not sure where to go from here. I'm at a loss. Any other ideas would be swell.. or if anyone can pick any holes in the way I went about this Im willing to go through it again in the case I might have goofed somehow.

    cheers,
    mambo
     
  5. gazzanova macrumors member

    Joined:
    Nov 29, 2008
    #5
    try this

    boot into single user mode

    Code:
    -s
    then

    Code:
    /sbin/fsck -fy
    you could get the message "Rows system was modified."

    now we mount the partition, otherwise we can't make modifications in the rows system, so you enter (MIND THE SPACE BETWEEN uw AND /!!!):

    Code:
    /sbin/mount -uw /
    now choose a password for your root account, so you type:

    Code:
    passwd root
    now the system will ask you to insert the new password, insert them and then press enter, rewrite and repress enter.
     
  6. mambo66 thread starter macrumors newbie

    Joined:
    Jan 4, 2009
    Location:
    Hong Kong
    #6
    Gazzanova,
    Interesting bit there. I am off the Mini problem for a few hours today but will give it a go and see what the results are. Will post the results back here. Thanks for the information... much appreciated.:)
     

Share This Page