Pages ’08 - proper quotation marks

Discussion in 'Mac Apps and Mac App Store' started by guifa, Sep 13, 2007.

  1. guifa macrumors 6502

    Joined:
    Sep 19, 2002
    Location:
    Auburn, AL
    #1
    This has bothered me since the first release of Pages. When you turn on typographic quotation marks, in English it puts them in properly as “ and ”. If you boot Pages in French, it does it correctly as « and ». For German it uses „ and ”, but for Spanish it idiotically uses “ ” instead of « ». I just installed Pages ’08 (university bookstore finally got in some copies) and it’s still broken.

    There still seems to be no definition for this in the Localizable.strings file which would make sense, so ... </vent> does anyone know how to edit these strings or a way to turn on correct marks in Spanish?
     
  2. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
    #2
    I don't know how to change them but have you given a feedback report to Apple yet?
     
  3. guifa thread starter macrumors 6502

    Joined:
    Sep 19, 2002
    Location:
    Auburn, AL
    #3
    There's been a bug report on it filed since November of 2005. I'm going to submit a new one since I suppose technically it's a different version.
     
  4. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
    #4
    I just noticed that a Puerto Rican Reggaeton musician posted a bulletin and it had the quotes you mentioned that Spanish should not have. Could it be that some countries are okay with them and not others? I had worked for a company doing a dual language version of their software and we had to pick our Spanish carefully.

    I should try Pages in Japanese to see what it does.
     
  5. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #5
    Interesting... Does the same thing happen in all system level text writers (Mail, TextEdit, Safari and so on)?
     
  6. guifa thread starter macrumors 6502

    Joined:
    Sep 19, 2002
    Location:
    Auburn, AL
    #6
    Well, similarly to in English, it's to some degree a question of preference. Eg, Americans use “” on the outside and ‘’*for inner, and Brits use ‘’*for outer, and “” for inner. French users also use “”*at times, although in all formal contexts afaik «» is mandatory (and is also supposed to have a quarter-space between the mark and the enclosed letters). The Royal Spanish Academy acknowledges the existance of “”*but as inner quotes. «» are the prefered outer quotes, and most monolingual publishers (like Cátedra) use them exclusively, with ‘’ for inner.

    There's an option for changing the language of the text currently being typed, and that affects both hyphenation and spell checking, but if you change it to French, for instance, it keeps it with “”. It's a shame that Apple has such great localization support in their frameworks (Unicode, a decent bit of OTF stuff, NSLocalized) but they don't actually use half of it (iPod can't display Hebrew, Arabic, Armenian, Thai song titles, but iTunes can okay, Mac OS X not localized to Russian or Arabic or Hebrew).

    To answer mad_jew's question ... no. At the system level, all quotation marks are actually ditto marks: "" because that's what typowriters used to have. You have to remember key combinations to curl them properly in English or any of the other latin script languages (not sure about the non-latin script ones). Mellel does this for a much larger number of languages, but I like the interface otherwise for Pages better and I can remember the key combinations for «*» (on my ISO Spanish, shift-option-´ and shift-option-ç).

    Also, I thought about doing an auto-correct for space, quote ( ") to « and quote, space (" ) to », but the autocorrect depends on spaces to activate it, so that doesn't work.
     

Share This Page