Panther has killed a G4

Discussion in 'General Mac Discussion' started by msbsound, Jan 19, 2004.

  1. msbsound macrumors regular

    Jul 16, 2002
    Charlotte, NC
    So here is the problem, that while I didn't create, I have been asked to fix. And with my limited knowledge, I turn to the tech Gods of macrumors since I am stumped. (okay buttkissing over)

    Here we go:

    A complete wipe and clean install of panther was done on a G4 400 tower with 896 megs of ram. The tower worked fine before in OS9 but now pretty much won't start up. By this I mean:

    Attempt 1: during the "welcome to panther setup" it froze while I was filling profile info.

    Attempt 2: same as above, but got far enough that the next boot made it to the desktop

    Attempt 3-5: As soon as I hit the desktop and the dock pops up the machine kernel panics, or, and I have never seen this: I get a series of command lines directly over the desktop. To make more clear, black bars of text just pop up in the left, upper corner of the screen. These still talk about kernel and mapping errors, but not with the normal greyed out screen and multiple languages.

    after all this I completely wiped the drives and started from scratch, while the results were slightly different, I am still at the same place.

    I have tried safe mode and I get the same results. In between I installed OS9 again, and of course that worked fine.

    I have tried removing ram and replacing them one at a time, no luck.

    I have zapped the pram twice, no luck.

    So that is where I am. Sorry for the long post, I have watched you guys help so many, please I am stuck!

  2. yoman macrumors 6502a


    Nov 11, 2003
    In the Bowels of the Cosmos
    you might have done this already but have you repaired the permissions of your local drive after installing panther. You can use the install disk as a boot up and repair permissions of your local drive from there.
  3. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    Even on a clean install, you can still end up with some drive errors.

    Running fsck and/or OS X's Disk First Aid off the Panther disk may catch some of them.
  4. msbsound thread starter macrumors regular

    Jul 16, 2002
    Charlotte, NC
    Still no luck

    First off, thank you for the ideas. Unfortunatly I am still having the same problems. Disks all checked out ok, and permissions repaired one thing. Also just to head this one off, firmware is fully up to date. I recieved that suggestion off another board, which made me realize I forgot to mention.

  5. davincijones macrumors newbie

    Feb 2, 2002
    Akron. Ohio
    Zero it out

    I had a similiar problem when installing Panther on a QS 733 with a 1.42 processor upgrade. The machine works fine after I ran disk utility and had it perform the 8 way read/write and then zero out the drive. It took a while. With a 80GB HD it took about 14 hours.

    Oh and after I installed Panther I had to repair permissions.

    But now everything is running perfectly.
  6. Horrortaxi macrumors 68020


    Jul 6, 2003
    Los Angeles
    Is there anything else in that computer that didn't come with it originally? PCI cards, RAM, processor upgrade? Those are the kinds of things that can cause problems.

    You did mention RAM. How much Apple RAM is there? If it's 128MB or more then take the rest out and see if you can boot normally.
  7. Dont Hurt Me macrumors 603

    Dont Hurt Me

    Dec 21, 2002
    Yahooville S.C.
    hope you installed the firmware update before trying to take such a old mac to the newest os. you did do this correct?
  8. msbsound thread starter macrumors regular

    Jul 16, 2002
    Charlotte, NC
    Many answers

    So the answers are:

    I have tried it with all ram configs, including using only the original config(64), which I knew panther would not accept.

    There are no upgrade cards or additional PCI cards installed. It is the original video card and original processor.

    Regarding the firmware, unfortunatly I do not know the answer. I was not the person who started this upgrade, just the person asked to solve it. Before I started, I updated the firmware via my OS 9 disk and my ipod...hey it worked...

    So I guess my new question is, if the people who did this upgraded the OS before the firmware, what am I to do, and what is wrong? ideas?

  9. applemacdude macrumors 68040


    Mar 26, 2001
    Over The Rainbow
    Yeah I remember a quote my computer teacher tols me"KISS" or Keep it simple stupid...(no offense)

    I would zero the drive using the os 9 disc like three times and then do it one more time with the panther disc...
  10. cubist macrumors 68020

    Jul 4, 2002
    Muncie, Indiana
    You may want to try depopulating some of the RAM.

    (fyi, I have a 500MHz Sawtooth, also 896MB, running Panther just fine.)
  11. bousozoku Moderator emeritus

    Jun 25, 2002
    Gone but not forgotten.
    It could be as simple as a USB device. I've had several situations with certain devices where the machine would freeze during boot.

    Try it after disconnecting all but the keyboard and the mouse.
  12. msbsound thread starter macrumors regular

    Jul 16, 2002
    Charlotte, NC
    Just an update

    So once again thank you to everyone for your time on this problem. Here is where I am at and it is still dead to the world.

    "KISS"ing it was my first step this morning. It couldn't have gotten any simpler. There is nothing installed on this machine that did not come from the factory aside from the ram, which I removed and tested methodically.

    What do you mean depopulate the ram? I have never heard of that.

    And I have tried booting the machine without even a keyboard or mouse attached to no avail.

    Currently, I am running Tech Tool through OS 9. It has found some catalog errors that it did not find this morning, but I am holding out little hope.

    The owner of the computer and the guy who started this whole install mess have asked me to revert to OS 9 if I don't get X going by the end of the day.

    I am not even the IT guy at the company, but maybe I should ask HIM to do my work, since he apparently can't do his. He claims to not know macs and in his defense the compmany only has 4, with 3 being in my office. Damn, what a long day.

    Sorry for the rant and thanks for the continued help everyone.
  13. msbsound thread starter macrumors regular

    Jul 16, 2002
    Charlotte, NC
    Back to 9

    just so everyone knows, I never found the problem and due to the timetable I was given. I had to return the machine to OS9. It is now happily chugging away, but I still have no idea why X would not take. I tried every version of X I had access to with no luck. Tech tool and apple hardware check all said the machine was A-ok. I removed everything possible from the machine, right down to it's factory setup. I zapped the pram, I updated firmware, I prayed to the almighty.

    Anyways, thanks to all who tried to help, and hopefully I will have another crack at the machine in it's next available down time.
  14. appleboy macrumors newbie

    Jan 24, 2004
    when or if you reinstall X hold down the x key during your first boot this forces x to boot up no matter what I am betting you had mismatched ram though that seems to much x up dimmfixit can handle that problem though
  15. Rower_CPU Moderator emeritus


    Oct 5, 2001
    San Diego, CA
    Maybe I missed it, but are you sure the Panther install disc is good? Errors during the install might be related to a damaged CD.

    Try with another disc, if you can.
  16. msbsound thread starter macrumors regular

    Jul 16, 2002
    Charlotte, NC
    Bad Panther Disc

    I tried using my copy for the third install and got the same results. I do hope for another crack at the machine sometime in the next two weeks. If I have better results, I will post it here.

  17. jaw04005 macrumors 601


    Aug 19, 2003
    Go grab some other brand of memory. I tried to load Panther and Jaguar on my old B&W G3. It displayed read & write errors, would freeze and kernal panic.... which led me to believe it was my hard drive. Replaced the hard drive, same thing. Then the other day I grabbed a stick of 512 out of an old Compaq of mine, and BAM started up like a charm. Crazy how picky about memory Mac OS X is, and the memory it was going nuts over was with what originally came w/ the G3! :eek:
  18. MacRAND macrumors 6502a


    May 24, 2003
    Phoenix AZ USA
    G4 400MHz goes crazy with Panther OS X

    The year 2000 vintage G4 towers do present a challenge. Starting February 2003, I helped a new MacBuddy upgrade to OS X, Jaguar then Panther. I know what you mean, been there and done that. Had to learn everything the hard way.
    He was running 9.0 (not even 9.2.2) had not changed a thing since he bought it.
    First thing I did was add a 7200 rpm 80GB hard drive "Macintosh HD" and made it the home for OS X, Classic and his data. Used the OEM 10GB HD as home base for OS 9.2.2.
    It finally ran very smoothly in the latest version of Jaguar, but initially had serious problems with original Panther, which has now cleared up with the updates.

    Added a $15 2 port USB 2.0 PCI card, abandoned his LaserWriter II printer and got a Canon i850 which he loves.

    You haven't told us about the "Hard Drives" he has, but I'll bet one is a small original (10GB?) and heaven knows what the other one is. Check them out using System Profiler.

    Now, these kernel panics are most likely either the RAM (I agree with the others) or there is something weird about that particular motherboard that doesn't like 10.

    Another thing we did to cure the panic attacks was wipe the hard drive and start over with a clean install of Panther, install all updates, and NOT have any partitions. I don't know what else to say or suggest you do, but I do know that old G4 tower should run OS X smoothly, and Panther is snappy compared to Jaguar.

    Now, before you guys spend very much money on any upgrades (or much more of your valuable time), realize that a 2 or 3-year newer used tower is likely to be a real bargain price-wise, and definitely in the performance area. Good luck. :cool:
  19. a2d macrumors newbie

    Jun 11, 2004
    Installation problems (iMac)

    I thought I'd post this experience here since this thread was the most useful in helping me work out what was going wrong.
    I'd installed Panther on a 350MHZ slot-loading indigo iMac (revB?) w/ built-in ethernet with absolutely no problems. I hardly ever used the mac running OS9, but as soon as it was able to see PC's on the network, it quickly became invaluable and I love OSX, even though it did crash a bit too often.
    But I ran into problems when I installed the recent OSX 10.3.4 Update. Basically that left the poor thing with no network connection - it would just not see the ethernet card.

    Pretty useless, so I cleared everything, went back to the OS9.0 disc (then downloaded and installed 9.1, 9.2.1, 9.2.2) then reinstalled Panther.
    That's when things really started going wrong - If it didn't panic immediately (95% of time) it would only get some way into the installation process and come up with the "Your computer needs to be restarted" screen.

    Three days attempting to reinstall and trying everyones ideas - re-inistialised disk, reset PRAM, NVRAM, swapped memory etc. to no avail.
    Appleboy's post about holding down X helped - at least it got through to begin the installation proper a bit more often.

    This was driving me mad, especially since it had installed fine the first time, so I wondered what could be different, and that's when I realised that in between the original installation and now, I'd bought a new mobile (cellphone) that had a desktop charger/syncstation which sat about 1.5 feet away from the mac between it and a PC laptop.
    Now, I live in an area with pretty bad reception, so the mobile is constantly trying to do whatever it does to work out reception. It was when I looked in the back of the iMac and saw that the memory is really pretty unsheilded that I thought "hey - it might be signals from the mobile causing problems".

    So, I started again with the mobile in another room - absolutely no problems. Installed fine first time. Now runs without crashing so often - fantastic.

    Only problem is I can't go near the iMac when on a call on the Mobile...

Share This Page