Resolved Permissions: "Loading…" inscription in the groups row of permissions section of "Get Info" window

Discussion in 'macOS' started by maverick28, Apr 5, 2017.

  1. maverick28 macrumors member

    Joined:
    Mar 14, 2014
    #1
    Hello,

    Troubleshooting another issue couple of months ago I had to restore Access Control Lists to the default values and I also performed reinstall of my OS (non-clean one). After that I got the word "Loading…" where usually group icon used to belong to at the bottom of Get Info Finder dialog (the screenshot). Everything works in normal mode, Disk Utility reports no problems with corrupted permissions. Still I can't understand what it is and is it normal?

    Permissions.png
     
  2. Superspeed500 macrumors regular

    Superspeed500

    Joined:
    Jul 25, 2013
    #2
    It's not normal that it says loading. Could you check what groups is set to owner as the file? Looks like the group that owns the file is missing. You can check what groups you have on your system by entering cat /etc/group | less into terminal (Press q to exit).

    UNIX permissions consist of three numbers that tell what permissions certain users have. The first number tells what permission the owning user have, the next shows owning group and the last shows everyone else.

    Example:
    My applications folder is set to 755 with me as owner and staff as owning group. That means that I have permissions to read, write and execute. The staff group have read and execute rights, but not write rights. Everyone else have the same rights.
     
  3. maverick28 thread starter macrumors member

    Joined:
    Mar 14, 2014
    #3
    Hi Superseed,

    My groups are these:

    staff com.apple.sharepoint.group.1 com.apple.access_screensharing everyone _appstore localaccounts _appserverusr admin _appserveradm _lpadmin _lpoperator _developer

    Also the permissions for my home folder are as follows:
    "drwxr-xr-x+"

    Still I see this annoying "Fetching" word like on the screenshot above. I don't know whether it cause some issues under hood.

    "staff" was what I used to see.
     
  4. Superspeed500, May 1, 2017
    Last edited: May 1, 2017

    Superspeed500 macrumors regular

    Superspeed500

    Joined:
    Jul 25, 2013
    #4
    What group owns the directory (you can check it with the ls -l command)?
    You could also try to run permission repair from disk utillity, to see if it fixes your problem.

    Edit: Creating a new directory with mkdir, then changing the group that owns the directory to a grop created by System preferences makes the "Fetching" appear on my Mac. Changing the owning group back to staff fixes the problem on my mac.
     
  5. maverick28 thread starter macrumors member

    Joined:
    Mar 14, 2014
    #5
    Superseed,

    My home folder belongs to staff. Disk Utility was of no help since it reported no problems, and so was 'resetpassword' in Recovery. I also noticed one more shortcoming: when I Option-click the plus button to add a group "staff" is missing. UNIX returns correct results but it's not on Finder level. I don't know how to create or reveal that "staff" group. The same thing happened in other account I created specifically for testing purpose. I created a directory with mkdir and it has this "Fetching" thingy. My main user UID is 501, the group's UID is 20. I'm on Lion.
     
  6. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #6
    Can you look at the ACL entries in Terminal?
    Code:
    ls -le

    Should be something like:
    Code:
    drwx------+   5 username  staff    170 Mar  5 15:47 Movies
     0: group:everyone deny delete
     
  7. maverick28 thread starter macrumors member

    Joined:
    Mar 14, 2014
    #7
    Ran this command 'ls- le /Users/' .
    There're 4 users:
    • my main user is showed as being a member of "staff". No "0: group:everyone deny delete" next to it.
    • Guest user is showed as being a member of "_guest". "0: group:everyone deny delete" appears next to it.
    • test user I referred above. "0: group:everyone deny delete" appears next to it.
    • root user ("wheel" group). No "0: group:everyone deny delete" next to it
     
  8. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #8
    And within your user directory, like shown in your screenshot? By the way, the root user is not supposed to have a directory there.
     
  9. maverick28 thread starter macrumors member

    Joined:
    Mar 14, 2014
    #9
    Within my home directory only entries for two subdirectories "Public" and "Sites" are appended with "0: group:everyone deny delete".
    --- Post Merged, May 3, 2017 ---
    Oops, my bad. That root wheel "0: group:everyone deny delete" is for "Shared" directory.
     
  10. maverick28 thread starter macrumors member

    Joined:
    Mar 14, 2014
    #10
    I yet been unable to find any explicit info on the correct unix structure of OS X and wasn't aware of that. Is it possible to solve?
    BTW, I have a log of the last reinstallation, maybe that could give a hint to the cause of the issue. Posting a OneDrive link to the log file (txt) in advance, since PASTEBIN rejected due to exceeded size limits (the log is 1MB which is too large for pastebin). It's completely safe.
    https://1drv.ms/t/s!Ar7_8hidDIZziBhA6EjqCGSV8oXh
     
  11. maverick28 thread starter macrumors member

    Joined:
    Mar 14, 2014
    #11
    It seems it has been resolved by itself. I reinstalled Lion once again without erase and now it correctly shows "staff" group in Get Info Finder window. Don't know what caused it this time to add the group but I guess it's something with Apple installation model and hit-and-miss results produced by it: it shouldn't be a norm to expect installation to break permissions and act unpredictably.
     

Share This Page