Philips 25" USB-C monitor cutting out

Discussion in 'Mac Accessories' started by rayjay86, May 28, 2017.

  1. rayjay86 macrumors 6502

    Joined:
    May 15, 2011
    #1
    I have the Philips 258b6queb USB-C monitor which I use with my Macbook Pro 13" with touchbar.

    The macbook pro is connected to the monitor via the included USB C cable. In the back of the monitor I have a 2TB USB 3.0 HDD, a wired USB Apple keyboard and in the apple keyboard USB ports a Logitech MX mouse.

    I love the monitor, the quality is great, etc.

    At the moment though, every now and then the monitor will go black. It usually happens when I'm not typing and I'm just moving the mouse around, or if I'm reading something. It'll go black for about 1s then the picture will come back.

    Its not turning off because the picture comes back immediately and the external HDD does not power off. Its really annoying if I'm watching something on Youtube though because the sound and picture will cut out for that two seconds.

    I can't figure out what it is. The cables are inserted tight and like I said, its not like violent movement is causing the black out. **Literally as I typed this sentence it did it!**

    What is going on? Anyone have similar issues with other monitors?
     
  2. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #2
    What happens if you disconnect ALL connections to the monitor, so that it is the monitor (and the monitor ALONE) that is running off its connection?
    (...with the keyboard, mouse and drive plugged into the OTHER USB port of the MacBook)?

    Suggestion:
    Try this setup scheme for 24 hours, and get back to us with the results.
     
  3. rayjay86 thread starter macrumors 6502

    Joined:
    May 15, 2011
    #3
    Oddly when I disconnected and tried it on the right lower USB c port, it became unusable. Flickering every few seconds. I disconnected and connected to the left upper port. Worked fine. Then to the left lower, fine. The. Back to the original port I had it in, no issues for the rest of the day and I was using it for a few hours after that.

    I'm not sure what the problem was.
    I don't have a USB c dock so I can't plug the others into the MacBook. At the moment it's working so I'm not sure what the issue was back then. Hopefully just a small glitch that doesn't rear its head again. The cables were definitely plugged in properly.
     

Share This Page