Phone is showing 3G but there is no Internet connection.

goneeuro

macrumors member
Original poster
May 4, 2009
71
0
I updated my fiancées iPhone 4 last night to 5.1 and now it has no 3G connection. It shows it has 3G with 4 bars of service but when she goes to Facebook or what's app it says there's no Internet connection available. Any ideas?
 

dave420

macrumors 65816
Jun 15, 2010
1,404
96
That has happened to me a few times. Usually turning the phone off and back on resolves it. Also you can try just turning on airplane mode for a second so it reconnects to the cellular network.
 

Sirolway

macrumors 6502
Jun 13, 2009
419
21
London
I get this ocassionally too. As the previous poster says, try flipping airplane mode on/off, or restarting the phone.

If that doesn't solve it, I assume I have a good signal but that the cell tower is swamped. Vodafone in the UK used to get this all the time at Liverpoool St Station in London; the entire City (financial district) was on Vodafone, so standing under the cell tower does no good is everyone else around you is also using it ..

Other times I've had it have been where the network operator has had an issue. Once they fix that, I'm back online.

Unfortunately we rely heavily on 'always-on' 3G+ mobile connectivity & it's just not really there yet - even in & around London I frequently have little / no / poor signal. It's very frustrating, but an opportunity to practice your Zen calm ;-)
 

goneeuro

macrumors member
Original poster
May 4, 2009
71
0
I tried rebooting the phone and a hard reset. I will have her try switching airplane mode. Her phone is on base in Germany.
 

cynics

macrumors G4
Jan 8, 2012
11,334
1,708
There is a certain area near Baltimore that the tower is so congested it's nearly unusable. So while I have good signal to it I have no Internet. I drive 20 minutes and it works great.

Have you tried a different location?
 

goneeuro

macrumors member
Original poster
May 4, 2009
71
0
Thanks for all the suggestions guys. Once she got home from work i played with her phone and figured it out. Because "Base" isn't a real iPhone carrier you have to set the APNs for everything. Well when i updated her phone the Internet apn got erased. I pulled out her Base contract stuff and put the APN back in and everything is good to go again. She was a little upset she had to go a whole day without Facebook. HA. But lesson learned, next update i will check to make sure that stuff doesn't get erased.
 

TonyC28

macrumors 68000
Aug 15, 2009
1,578
4,257
USA
Your solution obviously won't apply to me, but I wanted to chime in since I'm having the same problem on AT&T since upgrading to 5.1. After my upgrade I had to reset my network settings to get a solid connection. Before I did that my phone would drop the 4G (4G, what a crock, but anyways...) indicator completely and I'd have no Internet service. I have solved that problem by resetting the network settings. However, I occasionally have seemingly lost the connection even though the 4G indicator is still there and have to restart my phone to get it back.
Pretty annoying. I just had to do the same thing to my sister's phone as she was having the same problem