Phone keeps jumping/loosing cell service

bluerocka

macrumors newbie
Original poster
Jan 28, 2009
15
0
I am on AT&T and my phone keeps jumping back and forth from 4G to Edge in an area that I know I have 4G coverage. After a while it stops going to 4G and starts bouncing back and forth between Edge and no service. This usually happens when I change locations (go from home to work, work to the gym etc) or when I am in an area where this is no or low cell signal such as having the phone in my pocket or being in a basement.

I called Apple once and all they told me was turn cell data off and on again and then reboot the phone. They also suggested a restore (big surprise) which I ended up doing and then set it up as a new phone.

It seems that many times resetting the network settings will fix the problem, but I don't want to have to do this every time I go somewhere!

Does anyone have a similar problem or any other advice before I go back to Apple and ask for a new phone?
 

bluerocka

macrumors newbie
Original poster
Jan 28, 2009
15
0
That's what I figured... i put my iP5 next to my dads iP4 and both were on 4G, he had 3-4 bars, i had 1-2.
 

Huliodude

macrumors member
Aug 12, 2010
82
23
Mine's the same as OP, exactly. My iPhone 4 gets better signal than i5. Taking it in to Apple store to see if I can get it swapped out.
 

CmoranRVA

macrumors newbie
Oct 16, 2011
26
0
Had this exact problem on my original 5 and first replacement from Apple store. Got my second replacement today, haven't experienced the problem yet (nor the previous WIFI/WPA2 issue)...
 

Huliodude

macrumors member
Aug 12, 2010
82
23
Replaced my i5 today, new one is exactly the same unfortunately. That seems to be just how they are.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.